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Introduction

Charts and graphs can be powerful ways to convey information to the reader. LibreOffice Calc 
offers a variety of different chart and graph formats for your data.

Using Calc, you can customize charts and graphs to a considerable extent. Many of these options 
enable you to present your information in the best and clearest manner.

For readers who are interested in effective ways to present information graphically, two excellent 
introductions to the topic are William S. Cleveland’s The elements of graphing data, 2nd edition, 
Hobart Press (1994) and Edward R. Tufte’s The Visual Display of Quantitative Information, 2nd 
edition, Graphics Press (2001).

Chart Wizard

Calc uses a Chart Wizard to create charts or graphs from your spreadsheet data. After the chart 
has been created as an object in your spreadsheet, you can then change the chart type, adjust 
data ranges and the edit the chart using the functions available in the Chart Wizard. Each change 
you make using is automatically reflected in the chart object placed onto your spreadsheet. This is 
described in the following sections.

Creating charts and graphs

To demonstrate the process of creating charts and graphs in Calc, we will use example data as 
shown in Figure 1 to create a chart.

Figure 1: Example data for creating a chart

1) Select the cells containing the data to be included in the chart by highlighting (Figure 1). 
The selection does not need to be in a single block as in Figure 1; you can also choose 
individual cells or groups of cells (columns or rows). See Chapter 1 Introducing Calc for 
more information about selecting cells and ranges of cells.

2) Go to Insert > Chart on the main menu bar, or click the Chart icon  on the Standard 
toolbar to open the Chart Wizard dialog (Figure 2). A sample chart is created using the 
selected data and is placed onto the spreadsheet as an object (Figure 3).
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Figure 2: Chart Wizard dialog – selecting chart type

Figure 3: Example chart automatically created using Chart Wizard

Note

If you want to plot any unconnected rows or columns of data, select the first data 
series, then hold down the Ctrl key and select the next series. The two data series 
you are selecting must be in separate columns or rows. Otherwise Calc will assume 
that you are adding to the same data series.

Tip

Before opening the Chart Wizard, place the cursor or select a cell anywhere in the 
area of the data. The Chart Wizard will then guess the range of the data to create a 
sample chart. Just be careful that you have not included the title of your chart when 
you make your selection.
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Selecting chart type

Calc offers a choice of ten basic chart types and the options available vary according to the type of 
chart you select.

The initial chart created using the Chart Wizard is a normal column chart and by default it is a 2D 
chart. This is highlighted with a surrounding border in the preview box in Figure 2 and the chart 
name is shown below the preview.

To change the chart type:

1) Select the type of chart from the list in Choose a chart type (Figure 2).

2) Select a chart icon in the preview box and check to see if it is the chart type you require. 
For more information on chart types, see “Gallery of chart types” on page 31.

3) For Column, Bar, Pie or Area chart types only and if you want to use a 3D chart, select the 
checkbox 3D Look and select the type of 3D view for your chart (Realistic or Simple).

4) Select the options you want to use for your chart. The options available are dependent of 
the type of chart selected.

5) Click Next>> to move onto the next step in creating an example chart and make changes 
to the data range and axes labels (Figure 4).

6) If you are satisfied with your chart, click Finish to close the Chart Wizard and create an 
example chart object on your spreadsheet.

Note
To demonstrate the process of creating charts using the following sections, please 
leave the chart type as 2D column normal.

Figure 4: Chart Wizard dialog – selecting data range

Data range and axes labels

In the Data Range step of the Chart Wizard (Figure 4), you can manually correct any mistakes you 
have made in selecting the data for your chart, how your chart is plotted and how to label your 
chart.

1) If necessary, change the rows and columns used as data for your chart by editing the cell 
references in the Data range text box.
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2) Select whether to plot chart data by using either rows or columns as the data series. This is
useful if you use a chart type such as Donut or Pie to display your data.

3) Select whether to use the first row, or first column, or both, as labels for the axes of the 
chart.

4) Click Next>> to move onto the next step in creating an example chart and make changes 
to the data series (Figure 5).

5) If you are satisfied with your chart, click Finish to close the Chart Wizard and create an 
example chart object on your spreadsheet.

Note

A data range may consist of more than one region in a spreadsheet, for example 
"$Sheet1.A1:A5;$Sheet1.D1:D5" is also a valid data range.

If you want a data range of multiple cell areas that are not next to each other, enter 
the first range, then manually add a semicolon at the end of the text box, then enter 
the other ranges. Use a semicolon as delimiter between ranges.

Figure 5: Chart Wizard dialog – selecting data series

Data series

On the Data Series page of the Chart Wizard (Figure 5) you can change the source range of all 
data series separately, including their labels. You can also change the range of the categories and 
remove unnecessary data series or add data series from other cells.

Each named data series has its ranges and its individual Y-values listed. This is useful if you have 
very specific requirements for data in your chart, as you can include or leave out these ranges.

In the Data series list box you see a list of all data series in the current chart.

1) To organize the data series, select an entry in the Data series list.

2) Click Add to add another data series below the selected entry. The new data series has the
same type as the selected entry.

3) Click Remove to remove the selected entry from the Data series list.

4) Use the Up and Down buttons to move the selected entry in the list up or down. This does 
not change the order in the data source table, but changes only the arrangement in the 
chart.
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5) To change the cell reference that is used to name a data series, select an entry in the Data 
series list and edit the cell reference in the Range for Name text box.

6) To change the cell reference that is to give a category in a data series, select an entry in 
the Data series list and edit the cell reference in the Categories text box.

7) Click Next>> to move onto the next step in creating an example chart and make changes 
to the chart elements (Figure 7).

8) If you are satisfied with your chart, click Finish to close the Chart Wizard and create an 
example chart object on your spreadsheet.

Figure 6: Chart elements

Chart elements

The chart elements for 2D and 3D charts are shown in Figure 6.

• The chart wall contains the graphic of the chart displaying the data.

• The chart area is the area surrounding the chart graphic.

• The chart floor is only available for 3D charts.

• The chart title and subtitle, chart legend, axes labels and axes names are in the chart area 
and can be added when using the Chart Wizard to create a chart.

On the Chart Elements page (Figure 7), you can add or change the titles, axes names and grids. 
Use a title that draws the attention of viewers to the purpose of the chart and what you want them 
to see. Figure 6 shows the various chart elements that can be placed onto a chart.

1) Enter a title and subtitle you want to use in the Title and Subtitle text boxes. For example, 
a better title for this example chart might be The Performance of Motor and Other Rental 
Boats.

2) Enter a name you want to use in the X axis and Y axis text boxes, for example, 
Thousands for the Y axis. The Z axis text box is only active if you are creating a 3D chart.

3) Select the Display legend checkbox and where you want the legend displayed on your 
chart – Left, Right, Top or Bottom.

4) In Display grids, select the X axis or Y axis checkboxes to display a grid on your chart. The
Z axis checkbox is only active if you are creating a 3D chart. Grid lines are not available for
pie charts.
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5) Click Finish to close the Chart Wizard and create an example chart object on your 
spreadsheet.

Figure 7: Chart Wizard dialog – selecting and changing chart elements

Note
Clicking Finish closes the Chart Wizard, but the chart is still in edit mode and you 
can still modify it. Click outside the chart in any cell or a data series to complete the 
chart creation.

Editing charts and graphs

After you have created a chart, you may find that data has changed or you would like to improve 
the look of the chart. Calc provides tools for changing the chart type, chart elements, data ranges, 
fonts, colors, and many other options, and this is described in the following sections.

Changing chart type

You can change the chart type at any time.

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Go to Format > Chart Type on the main menu bar, or click the Chart Type icon  on the
Formatting toolbar, or right-click on the chart and select Chart Type from the context menu 
to open the Chart Type dialog. This is similar to the Chart Wizard dialog shown in Figure 2 
on page 7.

3) Select a replacement chart type you want to use. For more information, see “Selecting 
chart type” on page 7.

4) Click OK to close the dialog.

5) Click outside the chart to leave edit mode.
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Editing data ranges or data series

If the data range or data series has changed in your spreadsheet, you can edit them in your chart.

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Go to Format > Data Ranges on the main menu bar, or right-click on the chart and select 
Data Ranges from the context menu to open the Data Ranges dialog. This dialog has 
similar pages to the Chart Wizard dialogs shown in Figure 4 on page 7 and Figure 5 on 
page 8.

3) To edit the data range used for the chart, click on the Data Range tab. For more 
information, see “Data range and axes labels” on page 7.

4) To edit the data series used for the chart, click on the Data Series tab. For more 
information, see “Data series” on page 8.

5) Click OK to close the dialog.

6) Click outside the chart to leave edit mode.

Basic editing of chart elements

Basic editing of the title, subtitle and axes names in your chart is as follows. For more advanced 
editing, see the following sections.

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Go to Insert > Titles on the main menu bar, or right-click in the chart area and select Insert
Titles from the context menu to open the Titles dialog. This dialog is similar to the Chart 
Wizard dialog shown in Figure 7 on page 10.

3) Edit the text shown in the various text boxes.

4) Click OK to close the dialog.

5) Click outside the chart to leave edit mode.

Adding or removing chart elements

Titles, subtitles and axes names

Adding a title, subtitle or axes names to your chart is the same procedure as given in “Basic editing
of chart elements” above. To remove a title, subtitle or axes names from your chart:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Open the Titles dialog as above and delete the text from the various text boxes.

3) Click OK to close the dialog.

4) Click outside the chart to leave edit mode.

Legends

To add a legend to your chart:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Go to Insert > Legend on the main menu bar to open the Legend dialog. This dialog is 
similar to the Display legend section on the Chart Wizard dialog shown in Figure 7 on 
page 10.

3) Select the Display legend checkbox and where you want the legend displayed on your 
chart – Left, Right, Top or Bottom.
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4) Click OK to close the dialog.

5) Alternatively, right-click in the chart area and select Insert Legend from the context menu 
to insert a legend in the default position on the right side of the chart.

6) Click outside the chart to leave edit mode.

To remove a legend from your chart:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Go to Insert > Legend on the main menu bar to open the Legend dialog.

3) Deselect the Display legend checkbox.

4) Click OK to close the dialog.

5) Alternatively, right-click in the chart area and select Delete Legend from the context menu.

6) Click outside the chart to leave edit mode.

Axes

To add an axis to your chart:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Go to Insert > Axes on the main menu bar, or right-click on the chart and select 
Insert/Delete Axes from the context menu to open the Axes dialog (Figure 8).

3) Select the axes checkboxes that you want to use on your chart. The Z axis checkbox is 
only active if you are creating a 3D chart.

4) Click OK to close the dialog.

5) Click outside the chart to leave edit mode.

To remove an axis from your chart:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Open the Axes dialog as above and deselect the checkboxes for the axes you want to 
remove.

3) Click OK to close the dialog.

4) Click outside the chart to leave edit mode.

Figure 8: Axes dialog

Grids

The visible grid lines can help to estimate the data values in the chart. The distance of the grid 
lines corresponds to the interval settings in the Scale tab of the axis properties.
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Grid lines are not available for pie charts.

To add a grid to your chart:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Go to Insert > Grids on the main menu bar to open the Grids dialog. This is the same 
dialog as the Axes dialog (Figure 8), but it is titled Grids.

3) Select the grid checkboxes that you want to use on your chart. The Z axis checkbox is only
active if you are creating a 3D chart.

4) Click OK to close the dialog.

5) Click outside the chart to leave edit mode.

To remove a grid from your chart:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Open the Grids dialog as above and deselect the checkboxes for the grids you want to 
remove.

3) Click OK to close the dialog.

4) Click outside the chart to leave edit mode.

Data labels

Data labels put information about each data point on the chart. They can be very useful for 
presenting detailed information, but you need to be careful not to create a chart that is too cluttered
to read.

Figure 9: Data Labels dialog

Note
The text for data labels is taken from the spreadsheet data and it cannot be changed 
here. If the text needs to be abbreviated, or if it did not label your graph as you were 
expecting, you need to change it in the original data table.

To add data labels to your chart:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

Editing charts and graphs 13



2) Select the data series on your chart that you want to label. If you do not select a data 
series, then all data series on your chart will be labelled.

3) Go to Insert > Data Labels on the menu bar to open the Data Labels dialog (Figure 9).

4) Select the options that you want to use for data labels. The options available for data labels
are explained below.

5) Click OK to close the dialog.

6) Alternatively, right-click on the selected data series and select Insert Data Labels from the 
context menu. This method uses the default setting for the data labels.

7) Click outside the chart to leave edit mode.

To remove data labels from you chart:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Select the data labels on your chart that you want to remove.

3) Go to Insert > Data Labels on the menu bar, or right-click on the data labels and select 
Format Data Labels from the context menu to open the Data Labels dialog (Figure 9).

4) Make sure Data Labels page is selected in the dialog and deselect all the options for the 
data labels that you want to remove.

5) Click OK to close the dialog and remove the data labels.

6) Alternatively, right-click on the data series and select Delete Data Labels from the context 
menu.

7) Repeat the above steps to remove more data labels because you can only remove one 
data series at a time.

8) Click outside the chart to leave edit mode.

The options available for data labels in the Data Labels dialog are as follows.

• Show value as number – displays the numeric values of the data points. When selected, 
this option activates the Number format button.

• Number format – opens the Number Format dialog, where you can select the number 
format. This dialog is very similar to the one for formatting numbers in cells, see Chapter 2 
Entering, Editing, and Formatting Data for more information.

• Show value as percentage – displays the percentage value of the data points in each 
column. When selected, this option activates the Percentage format button.

• Percentage format – opens the Number Format dialog, where you can select the 
percentage format. This dialog is very similar to the one for formatting numbers in cells, see
Chapter 2 Entering, Editing, and Formatting Data for more information.

• Show category – shows the data point text labels.

• Show legend key – displays the legend icons next to each data point label.

• Separator – selects the separator between multiple text strings for the same object (if at 
least two options above are selected).

• Placement – selects the placement of data labels relative to the objects.

• Rotate Text – click in the dial to set the text orientation for the data labels or enter the 
rotation angle for the data labels.

• Text Direction – specify the text direction for a paragraph that uses Complex Text Layout 
(CTL). This feature is only available if CTL support is enabled.

Trend lines

When you have a scattered grouping of points in a graph, you may want to show the relationship of
the points by using a trend line. Calc has a good selection of regression types you can use for 
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trend lines: linear, logarithm, exponential, and power. Choose the type that comes closest to 
passing through all of the points.

Trend lines can be added to all 2D chart types except for pie and stock charts. If a data series is 
selected, a trend line is inserted for that data series only. If no data series are selected, trend lines 
are inserted for all data series.

When inserted, trend lines are automatically shown in the chart legend.

Figure 10: Trend Lines dialog

To insert trend lines to your chart:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Select the data series on your chart that you want to use to insert trend lines. If you do not 
select a data series, then trend lines for all data series on your chart will be inserted.

3) To insert trend lines for all data series, go to Insert > Trend Lines on the main menu bar to
open the Trend Lines dialog (Figure 10).

4) To insert a trend line for a single data series, select a data series then go to Insert > Trend 
Lines on the main menu bar, or right-click on the data series and select Insert Trend Line 
from the context menu to open the Trend Lines dialog for the selected data series.

Note
The dialog to insert a trend line for a single data series is similar to the dialog for all 
data series (Figure 10), but has a second page called Line where you can select the 
formatting for the trend line (style, color, width, and transparency).

5) Select the type of trend line that you want to insert – Linear, Logarithmic, Exponential, or 
Power.

6) To show the equation or coefficient of determination used to calculate the trend lines, select
the options Show equation and/or Show coefficient of determination (R2).

7) Click OK to close the dialog and the trend lines are placed onto your chart.

8) Click outside the chart to leave edit mode.
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Note
When inserted, a trend line has the same color as the corresponding data series. To 
change the trend line properties, right-click on the trend line and select Format 
Trend Line on the context menu to open the Line page of the Trend Lines dialog.

To show the equation or the coefficient of determination and the equation after a trend line has 
been inserted, right-click on the trend line and select Insert Trend Line Equation or Insert R2 and
Trend Line Equation from the context menu. For more information on the equations, see the topic
Trend Lines in the LibreOffice Calc Help.

When you select a trend line, the information for the trend line is shown in the Status Bar, which is 
normally located at the bottom of the spreadsheet.

To delete trend lines from your chart:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) To delete all trend lines, go to Insert > Trend Lines on the main menu bar to open the 
Trend Lines dialog and select None then click OK.

3) To delete a single trend line, right-click on the data series and select Delete Trend line 
from the context menu.

Mean value lines

Mean value lines are special trend lines that show the mean value and can only be used in 2D 
charts. If a data series is selected, a mean value line is inserted for that data series only. If no data 
series are selected, mean value lines are inserted for all data series.

When you insert mean value lines into your chart, Calc calculates the average of each selected 
data series and places a colored line at the correct level in the chart. The colored line uses the 
same color as that used for the data series.

To insert mean value lines on your chart:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Select the data series on your chart that you want to use to insert mean value lines. If you 
do not select a data series, then mean value lines for all data series on your chart will be 
inserted.

3) To insert mean value lines for all data series, go to Insert > Mean Value Lines on the main
menu bar.

4) To insert a mean value line for a single data series, select a data series then go to Insert > 
Mean Value Lines on the main menu bar, or right-click on the data series and select Insert
Mean Value Line from the context menu.

5) Click outside the chart to leave edit mode.

To delete mean value lines from your chart:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Select the mean value line you want to delete and press the Delete key, or right-click on the
data series and select Delete Mean Value Line from the context menu.

3) Click outside the chart to leave edit mode.

X or Y error bars

Use the X and Y error bars to display error bars for 2D charts only. If a data series is selected, an X
or Y error bar is inserted for that data series only. If no data series are selected, X or Y error bars 
are inserted for all data series.

Editing charts and graphs 16



If you are presenting data that has a known possibility of error, such as social surveys using a 
particular sampling method, or you want to show the measuring accuracy of the tool you used, you 
may want to show error bars on the chart.

To insert error bars to your chart:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

Figure 11: Error Bars dialog

2) Select the data series on your chart that you want to use to insert error bars. If you do not 
select a data series, then error bars for all data series on your chart will be inserted.

3) To insert error bars for all data series, go to Insert > X Error Bars or Insert > Y Error Bars
on the main menu bar to open the Error Bars dialog (Figure 11).

4) To insert error bars for a single data series, select a data series then go to Insert > X Error 
Bars or Insert > Y Error Bars on the main menu bar, or right-click on the data series and 
select Insert X Error Bars or Insert Y Error Bars from the context menu to open the Error 
Bars dialog.

5) Select the required options in Error Category, Error Indicator or Parameters to use for the 
error bars. More information on the options for error bars is given below.

6) Click OK to close the dialog and insert the error bars onto your chart.

7) Click outside the chart to leave edit mode.

To delete error bars from your chart:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) To delete error bars for all data series, go to Insert > X Error Bars or Insert > Y Error 
Bars on the main menu bar to open the Error Bars dialog (Figure 11) and select None in 
Error Category.

3) Click OK to close the dialog and delete the error bars from your chart.

4) To delete error bars from a single data series, right-click on the data series and select 
Delete X Error Bars or Delete Y Error Bars from the context menu.

5) Click outside the chart to leave edit mode.

Several options are provided on the X or Y Error Bars dialog. You can select only one error 
category at a time. You can also select whether the error indicator shows both positive and 
negative errors, or only positive or only negative.
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• Constant value – you can have separate positive and negative values.

• Percentage – choose the error as a percentage of the data points.

• The drop-down list has four options as follows:

– Standard error

– Variance – shows error calculated on variance

– Standard deviation – shows error calculated on standard deviation

– Error margin – you designate the error

• Cell Range – calculates the error based on cell ranges you select. The Parameters section
at the bottom of the dialog changes to allow selection of the cell ranges.

Formatting charts and graphs

Calc provides many options for formatting and fine-tuning the appearance of your charts. To enter 
formatting mode for your chart:

Selecting chart elements

Depending on the purpose of your document, for example a screen presentation or a printed 
document for a black and white publication, you might wish to have more detailed control over the 
different chart elements to give you what you need.

To select a chart element:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Select the chart element that you want to format and the chart element will be highlighted 
with selection squares or a border of square selection handles. Each chart element has its 
own formatting options and these are explained below.

3) Go to Format on the main menu bar and select the relevant option, or right-click to display 
a context menu relevant to the selected element to open the relevant formatting dialog.

Note

If your chart has many elements, it is recommended to turn on tooltips in Tools > 
Options > LibreOffice > General. When you hover a cursor over an element, Calc 
will display the element name which will making it easier in selecting the correct 
element. The name of the selected element also appears in the Status Bar.

Formatting options

• Format Selection – opens a dialog where you can specify the area fill, borders, 
transparency, characters, fonts, and other attributes of the selected element on the chart.

• Position and Size – opens the Position and Size dialog (see “Position and Size dialog” on 
page 29).

• Arrangement – provides two options: Bring Forward and Send Backward, of which only 
one may be active for some items. Use these options to arrange overlapping data series.

• Title – formats the titles for the chart and chart axes.

• Legend – formats how the legend appears and positioned on the chart

• Axis – formats the lines that create the chart as well as the font of the text that appears on 
both the X and Y axes.
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• Grid – formats the lines that create a grid for the chart.

• Chart Wall, Chart Floor, or Chart Area – formats how the chart wall, chart floor and chart 
area appear on your chart. Note that the chart floor is available for 3D charts.

• Chart Type – changes what type of chart is displayed and whether it is 2D or 3D chart. 
Note that only column, bar, pie and area charts can be displayed as a 3D chart.

• Data Ranges – explained in “Data range and axes labels” on page 7 and “Editing data 
ranges or data series” on page 11.

• 3D View – formats 3D charts and is only available for 3D charts (see page 20).

Moving chart elements

You may wish to move or resize individual elements of a chart, independent of other chart 
elements. For example, you may wish to reposition the legend from its default position on the right 
of the chart to below the chart. Pie charts also allow moving of individual wedges of the pie as well 
as exploding the entire pie. However, you cannot move an individual point or data series.

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Move the cursor over the chart element you want to move, then click and drag to move the 
element. If the element is already selected, then the cursor changes to the move icon 
(normally a small hand), then click and drag to move the element.

3) Release the mouse button when the element is in the desired position.

Note

If your chart is a 3D chart, then round selection handles appear when a 3D chart 
element is selected. These round selection handles control the 3D angle of the 
element. You cannot resize or reposition the element while the round selection 
handles are showing. Use Shift+Click to get the square selection handles and you 
can now resize and reposition your 3D chart graphic.

Changing chart area background

The chart area is the area surrounding the chart graphic, including the main title, subtitle and 
legend.

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Go to Format > Chart Area on the main menu bar or right-click in the chart area and select
Format Chart Area from the context menu to open the Chart Area dialog (Figure 12).

3) Select the desired formatting from the Borders, Area and Transparency pages.

4) Click OK to close the dialog and save your changes.

Changing chart graphic background

The Chart Wall is the area that contains the chart graphic.

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Go to Format > Chart Wall on the main menu bar or right-click in the chart area and select 
Format Chart Area from the context menu to open the Chart Wall dialog. This dialog is 
similar to the Chart Area dialog in Figure 12.

3) Select the desired formatting from the Borders, Area and Transparency pages.

4) Click OK to close the dialog and save your changes.

Formatting charts and graphs 19



Figure 12: Chart Area dialog

Changing colors

If you want to modify the color scheme from the default, or you want to add extra chart colors for 
charts in all your documents, go to Tools > Options > Charts > Default Colors top make the 
changes. Changes made in this dialog affect the default chart colors for any chart you make in the 
future. See the Getting Started Guide for more information on changing colors.

3D charts

The 3D View dialog (Figure 13) has three pages:

• Perspective – where you can change the perspective of the chart.

• Appearance – Select whether to use a simple or realistic scheme for your 3D chart.

• Illumination – controls the light source that illuminates your 3D chart and where the 
shadows will fall.

Figure 13: 3D View dialog – Perspective page
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Rotation and perspective

To rotate a 3D chart or change its perspective view:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Go to Format > 3D View on the main menu bar or right-click in the chart area and select 
3D View from the context menu to open the 3D View dialog (Figure 13).

3) Click on the Perspective tab to open the page.

4) Enter the required settings for Right angled axes and Perspective.

5) Click OK to close the dialog and save your changes.

Some hints for using the Perspective page:

• Set all angles to 0 for a front view of the chart. Pie charts and donut charts are shown as 
circles.

• With Right-angled axes enabled, you can rotate the chart contents only in the X and Y 
direction; that is, parallel to the chart borders.

• An X value of 90, with Y and Z set to 0, provides a view from the top of the chart. With X set
to –90, the view is from the bottom of the chart.

• Rotation is applied in the following order: X-axis first, then Y-axis, and Z-axis last.

• When shading is enabled and you rotate a chart, the lights are rotated as if they are fixed to
the chart.

• The rotation axes always relate to the page, not to the axes of the chart. This is different 
from some other chart programs.

• Select the Perspective option to view the chart in central perspective as through a camera 
lens instead of using a parallel projection. Set the focus length with the spin button or type 
a number in the box. 100% gives a perspective view where a far edge in the chart looks 
approximately half as big as a near edge.

Rotating 3D charts interactively

In addition to using the Perspective page of the 3D View dialog to rotate 3D charts, you can also 
rotate 3D charts interactively.

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Select the Chart Wall and round selection handles appear.

3) Hover the mouse cursor over a corner handle and the cursor changes to a rotation icon.

4) Press and hold the left mouse button and drag the direction you want. A dashed outline of 
the chart is visible while you drag to help you see how the result will look.

5) Release the mouse button when satisfied.

Appearance

Use the Appearance page to modify some aspects of the appearance of a 3D chart.

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Go to Format > 3D View on the main menu bar or right-click in the chart area and select 
3D View from the context menu to open the 3D View dialog (Figure 14).

3) Click on the Appearance tab to open the page.

4) Select a scheme from the Scheme drop down list box – Realistic (default) or Simple. When 
you select a scheme, the options and the light sources are set accordingly.
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Figure 14: 3D View dialog – Appearance page

5) If necessary, select or deselect a combination of Shading, Object borders, or Rounded 
edges that is not given by the Realistic or Simple schemes to create a Custom scheme.

6) Click OK to close the dialog and save your changes.

Some hints for the Appearance page. Depending on the scheme selected, not all options are 
available.

• Select Shading to use the Gouraud method for rendering the surface. Otherwise, a flat 
method is used. The flat method sets a single color and brightness for each polygon. The 
edges are visible, soft gradients and spot lights are not possible. The Gouraud method 
applies gradients for a smoother, more realistic look. See the Draw Guide for more 
information on the use of shading.

• Select Object borders to draw lines along the edges.

• Select Rounded edges to smooth the edges of box shapes.

Illumination

Use the Illumination page (Figure 15) to set the light sources for the 3D view. See the Draw 
Guide for more information on setting the illumination.

Figure 15: 3D View dialog – Illumination page

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Go to Format > 3D View on the main menu bar or right-click in the chart area and select 
3D View from the context menu to open the 3D View dialog (Figure 15).

3) Click on the Illumination tab to open the page.
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4) Click any of the eight buttons to switch a directed light source on or off. By default, the 
second light source is switched on. It is the first of seven normal, uniform light sources. The
first light source projects a specular light with highlights.

5) For the selected light source, select a color from the drop down list just below the eight light
source buttons. Note that the brightness values of all lights are added together, so use dark
colors when you enable multiple lights.

6) Each light source always points at the middle of the object initially. If necessary, change the
position of the light source by moving the vertical and/or horizontal sliders to set position of 
the selected light source.

7) Check the small preview on the dialog to see the effect of repositioning the light source.

8) Click the button in the bottom right corner of the preview to switch the internal illumination 
model between a sphere and a cube.

9) Select the ambient light using the Ambient light drop down list to define the ambient light 
which shines with a uniform intensity from all directions.

10) Click OK to close the dialog and save your changes.

Grids

You can divide the axes into sections by assigning gridlines to them. This allows you to get a better
overview of the chart, especially if you are working with large charts. The Y axis major grid is 
activated by default.

Use the Grid dialog to set the formatting options for the lines used as grids in your chart by 
selecting line style, color, width and transparency. The dialog is similar to the Line page in the 
Chart Area dialog shown in Figure 12 on page 20.

Axes

Sometimes you need to have a special scale for one of the axes of your chart, or you need smaller 
grid intervals, or you want to change the formatting of the labels on the axis. After highlighting the 
axis you wish to change, right-click and choose one of the items from the context menu.

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Go to Format > Y Axis or X Axis on the main menu bar and select the axis you want to 
format, or right-click in on the chart the axis you want to format and select Format Axis 
from the context menu to open the Axis dialog (Figure 16). The options available in the 
dialog depend on which axis was selected, type of axis used, type of chart and whether the
chart is 2D or 3D.

Figure 16: Y Axis dialog – Scale page
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3) Click on the tab of the page where you to make changes using the available options. The 
options for each page are explained below.

4) Click OK to close the dialog and save your changes.

Scale

You can enter values for subdividing axes on the Scale page (Figure 16).

• Reverse direction – defines where the lower and the higher values are displayed at the 
axis. Deselect this option to use a mathematical direction. That means for Cartesian 
coordinate systems that the X-axis shows the lower values on the left and the Y-axis shows
the lower values at the bottom. For polar coordinate systems, the mathematical angle axis 
direction is counterclockwise and the radial axis is from inner to outer.

• Logarithmic scale – specifies that you want the axis to be subdivided logarithmically. Use 
this option if you are working with values that differ sharply from each other. You can use 
logarithmic scaling to make the grid lines of the axis equidistant but have values that may 
increase or decrease.

• Minimum – defines the minimum value for the beginning of the axis. Automatic must be 
deselected to set this option manually.

• Maximum – defines the maximum value for the end of the axis. Automatic must be 
deselected to set this option manually.

• Major interval – defines the interval for the main division of the axes. The main interval 
cannot be larger than the value area. Automatic must be deselected to set this option 
manually.

• Minor interval count – defines the interval for the subdivision of the axes. Automatic must
be deselected to set this option manually.

• Automatic – you must first deselect this option to modify the values. Disable this option if 
you are working with fixed values, as it does not permit automatic scaling.

• Type – for some types of axes, you can select to format an axis as text or date, or to detect
the type automatically. For a data axis type, you can set the following options.

– Minimum and maximum value to be shown on the ends of the scale.

– Resolution can be set to show days, months, or years as interval steps.

– Major interval can be set to show a certain number of days, months, or years.

– Minor interval can be set to show a certain number of days, months, or years.

Figure 17: Y Axis dialog – Positioning page
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Positioning

The Positioning page (Figure 17) controls the positioning of the axis.

• Axis line – select where Cross other axis at from the drop down list – Start, End, or at a 
specified Value.

• Labels – select where Place labels: is set from the drop down list – Near axis, Near axis 
(other side), Outside start, or Outside end.

• Interval marks

– Major – specifies whether the marks are to be on the inner or outer side of the axis. It is
possible to combine both: you will then see marks on both sides. Inner – specifies that 
marks are placed on the inner side of the axis. Outer – specifies that marks are placed 
on the outer side of the axis.

– Minor – defines the marking dashes between the axis marks. It is possible to activate 
both fields. This will result in a marking line running from the outside to the inside.

– Inner – specifies that minor interval marks are placed on the inner side of the axis.

– Outer – specifies that minor interval marks are placed on the outer side of the axis.

– Place marks – select where to place the marks from the drop down list – At labels, At 
axis, or At axis and labels.

Line

Use the Line page to set the formatting options for the axis line by selecting line style, color, width, 
and transparency. The dialog is similar to the Chart Area dialog shown in Figure 12 on page 20.

Figure 18: Y Axis dialog – Label page

Label

On the Label page (Figure 18), you can decide whether to show or hide the labels, how to handle 
them when they will not all fit neatly into one row (for example, if the words are too long), and 
whether to have them at an angle to the axis.
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• Show labels – specifies whether to show or hide the axis labels.

• Order – the options on this page are only available for a 2D chart. In this area, you can 
define the alignment of the number labels on the X or Y axis.

– Tile – arranges numbers on the axis side by side.

– Stagger odd – staggers numbers on the axis, even numbers lower than odd numbers.

– Stagger even – stagger numbers on the axes, odd numbers lower than even numbers.

– Automatic – automatically arranges numbers on the axis.

Note
Problems may arise in displaying labels if the size of your chart is too small. You can 
avoid this by either enlarging the view or decreasing the font size.

• Text flow – determines the text flow of the axis label.

– Overlap – specifies that text in axis labels may overlap other axis labels. This can be 
especially useful if there is a lack of space.

– Break – allows a text break.

• Text direction – defines the text direction of labels.

– ABCD wheel – click and drag the indicator on the wheel defines the variable text 
orientation. The characters "ABCD" on the wheel correspond to the new setting.

– Vertically stacked – assigns vertical text orientation for labels. If you define a vertical 
X-axis label, the text may be cut off by the line of the x-axis.

– Degrees – manually enter the orientation angle for the labels.

– Text direction – specify the text direction for any text that uses complex text layout 
(CTL) and is only available if Enhanced language support is enabled In Tools > 
Options > Language Settings.

Numbers

Use the Numbers page to set the attributes for any numbers used on the axis. This page is very 
similar to the one for formatting numbers in cells; see Chapter 2 Entering, Editing, and Formatting 
Data for more information.

Font and Font Effects

Use the Font and Font Effects pages to set the attributes for fonts and the type of font effects used 
for axis labels. These pages are very similar to the ones for fonts and font effects in cells; see 
Chapter 2 Entering, Editing, and Formatting Data for more information.

Asian Typography

Sets the Asian typographic options for axis labels and is only available if Enhanced language 
support is enabled In Tools > Options > Language Settings.

• Apply list of forbidden characters to the beginning and end of line – prevents the 
characters in the list from starting or ending a line. The characters are relocated to either 
the previous or the next line. To edit the list of restricted characters, go to Tools > Options 
> Language Settings > Asian Layout.

• Allow hanging punctuation – prevents commas and periods from breaking the line. 
Instead, these characters are added to the end of the line, even in the page margin.

• Apply spacing between Asian, Latin and Complex text – inserts a space between 
Asian, Latin and complex characters.
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Hierarchical axis labels

Multiple columns of categories can be displayed in a hierarchical manner at the axis on your chart. 
Hierarchical axes labels are created automatically if the first columns (or rows) contain data that is 
text. An example of hierarchical labels is shown in Figure 19 where the first column indicates the 
quarters and the second column shows the months.

Figure 19: Example of hierarchical axes labels

Figure 20: Data Series dialog – Line page
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Selecting and formatting symbols

In line and scatter charts the symbols representing the points can be changed to a different symbol
or color through the object properties dialog.

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Select the data series you want to change.

3) Go to Format > Format Selection on the main menu bar or right-click and select Format 
Data Series from the context menu to open the Data Series dialog (Figure 20).

4) Open the Line page of the Data Series dialog by clicking on its tab.

5) In the Icon section, open the drop-down list and select an option for your symbol from No 
symbol, Automatic, From file, Gallery or Symbols. A preview of your selection is shown in 
the preview box at the bottom of the dialog.

– From file opens a file browser so you can select a file to use for your symbol.

– Gallery opens a list showing the available graphics you can select for your symbol.

– Symbols opens a list showing the available symbols you can select.

6) Enter the Width and the Height you want to use for your new symbol.

7) Select Keep ratio if you want the width and height of your symbol to maintain its ratio.

Adding drawing objects to charts

As in the other LibreOffice components, you can use the Drawing toolbar to add shapes such as 
lines, rectangles, circles, text objects, or more complex shapes such as symbols or block arrows. 
Use these additional shapes to add explanatory notes and highlight points on your chart, for 
example. For more information on using the Drawing toolbar and drawing shapes, see the Draw 
Guide.

Resizing and moving the chart

You can resize or move all elements of a chart at the same time, in two ways: interactively, or by 
using the Position and Size dialog. You can use a combination of both methods: interactive for a 
quick and easy change, then the Position and Size dialog for precise sizing and positioning.

Interactively

To resize a chart interactively:

1) Click once on the chart to select it and square selection handles appear around the border 
of the chart.

2) To increase or decrease the size of the chart, click and drag one of the markers. The cursor
indicates the direction in which you can increase or decrease the chart size.

To move a chart interactively:

1) Click once on the chart to select it and square selection handles appear around the border 
of the chart.

2) Hover the cursor anywhere over the chart until it changes to a move cursor (shape 
depends on computer setup).

3) Click and drag the chart to its new location.

4) Release the mouse button when the chart is in the required position.

Resizing and moving the chart 28



Position and Size dialog

To resize or move a chart using the Position and Size dialog:

1) Click once on the chart to select it and square selection handles appear around the border 
of the chart.

2) Right-click and select Position and Size from the context menu to open the Position and 
Size dialog (Figure 21).

3) Select the options you want to use ion the Position and Size, Rotation and Slant & corner 
Radius pages on this dialog.

4) Click OK to close the dialog and save your changes.

Position and size of a chart are coordinated relative to a fixed point (the base point) and, by 
default, this base point is located at the upper left of a chart. You can temporarily change this base 
point to make positioning or sizing of a chart simpler. Click one of the points in Base point 
corresponding to the location you want to use for either Position or Size. When you click OK and 
close this dialog, Calc resets the base point to the default position.

Figure 21: Position and Size dialog

Position and Size

The options available on the Position and Size page (Figure 21) are as follows:

• Position – specify the location of the selected object on the page.

– Position X – enter the horizontal distance that you want to move the object relative to 
the base point selected in the grid.

– Position Y – enter the vertical distance that you want to move the object relative to the 
base point selected in the grid.

– Base point – select a base point in the grid, and then enter the amount that you want to
shift the object relative to the base point that you selected in the Position Y and 
Position X boxes. The base points correspond to the selection handles on an object.

• Size – specify the amount by which you want to resize the selected object with respect to 
the selected base point.

– Width – enter a width for the selected object.
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– Height – enter a height for the selected object.

– Keep ratio – maintains proportions between width and height when you resize the 
selected object.

– Base point – select a base point in the grid and then enter the new size dimensions for 
the selected object in the Width and Height boxes.

• Protect – prevents changes to the position or the size of the selected object.

– Position – prevents you from moving the object.

– Size – prevents you from resizing the object.

• Adapt – specifies if the size should be adjusted to fit the size of entered text.

– Fit width to text – expands the width of the object to the width of the text, if the object is 
smaller than the text.

– Fit height to text – expands the height of the object to the height of the text, if the object
is smaller than the text.

Rotation

The options for the Rotation page (Figure 22) are as follows:

• Pivot point – the selected object is rotated around a pivot point that you specify. The 
default pivot point is at the center of the object. If you set a pivot point too far outside of the 
object boundaries, the object could be rotated off of the page.

– Position X – enter the horizontal distance from the left edge of the page to the pivot 
point.

– Position Y – enter the vertical distance from the top edge of the page to the pivot point.

– Default settings – select where you want to place the pivot point on the object. The 
default setting is the center of the object.

• Rotation angle – specify the number of degrees that you want to rotate the selected 
object, or click in the rotation wheel.

– Angle – enter the number of degrees that you want to rotate the selected object.

– Default settings – click and drag the indicator to specify the rotation angle in degrees. 
The number of degrees rotated is shown in the Angle box.

Figure 22: Position and Size dialog – Rotation page
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Slant & Corner Radius

The options for the Slant & Corner Radius page (Figure 23) are as follows:

• Corner Radius – you can only round the corners of a rectangular object.

– Radius – enter the radius of the circle that you want to use to round the corners.

• Slant – slants the selected object along an axis that you specify.

– Angle – enter the angle of the slant axis.

Figure 23: Position and Size dialog – Slant & Corner Radius page

Exporting charts

You can export a chart as a graphic that you can use in other documents.

1) Click once on the chart to select it. Square selection handles appear around the border of 
the chart.

2) Right-click on the selected chart and select Export as graphic from the context menu.

3) In the Graphics Export dialog that opens, type a name for the graphic file, select the 
location where you want to save the file, and select the graphic format you want to use.

4) Click Save and your chart will be exported as a graphic to the location you specified and 
the format you specified.

Gallery of chart types

It is important to remember that while your data can be presented with a number of different charts,
the message you want to convey to your audience should determine what type of chart you use. 
The following sections present examples of the chart types that Calc provides, with some notes on 
the purpose of each chart type.

Column charts

Column charts are commonly used for data that shows trends over time. They are best for charts 
that have a relatively small number of data points. It is the default chart type provided by Calc, as it
is one of the most useful charts and the easiest to understand. If you have a large time series, a 
line chart would be better suited.

A column chart shows vertical bars, with the height of each bar being proportional to its value. The 
X-axis shows categories and the Y-axis shows the value for each category.

• Normal – this subtype shows all data values belonging to a category next to each other. 
The main focus is on the individual absolute values, compared to every other value.

• Stacked – this subtype shows the data values of each category on top of each other. The 
main focus is the overall category value and the individual contribution of each value within 
its category.
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• Percent – this subtype shows the relative percentage of each data value with regard to the 
total of its category. The main focus is the relative contribution of each value to the category
total.

You can enable a 3D view of the data values. A realistic 3D chart tries to give the best 3D look 
while a simple 3D chart tries to mimic the chart view of other products.

For 3D charts, you can select the shape of each data value from Box, Cylinder, Cone, and 
Pyramid.

Bar charts

A bar chart shows horizontal bars. The length of each bar is proportional to its value. The Y-axis 
shows categories and the X-axis shows the value for each category. The subtypes for bar charts 
are the same as for column charts, given above.

Bar charts are excellent for giving an immediate visual impact for data comparison in cases when 
time is not an important factor, for example, when comparing the popularity of a few products in a 
marketplace. In the examples below:

• The first chart is achieved by using the chart wizard with Insert > Grids, deselecting y-axis,
and using Insert > Mean Value Lines.

• The second chart is a 3D chart created with a simple border and the 3D chart area twisted 
around.

• The third chart is an attempt to get rid of the legend and put labels showing the names of 
the companies on the axis instead. We also changed the colors to a hatch pattern.

Figure 24: Bar chart examples

Pie charts

A pie chart shows values as circular sectors of the total circle. The length of the arc, or the area of 
each sector, is proportional to its value.

• Pie – this subtype shows sectors as colored areas of the total pie, for one data column 
only. In the created chart, you can click and drag any sector to separate that sector from 
the remaining pie or to join it back.

• Exploded pie – this subtype shows the sectors already separated from each other. You 
can click and drag any sector to move it along a radial from the pie center.

• Donut – this subtype can show multiple data columns. Each data column is shown as one 
donut shape with a hole inside, where the next data column can be shown. You can click 
and drag an outer sector to move it along a radial from the donut center.
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• Exploded donut – this subtype shows the outer sectors already separated from the 
remaining donut. You can click and drag an outer sector to move it along a radial from the 
donut's center.

Pie charts are excellent when you need to compare proportions. For example, comparisons of 
departmental spending: what the department spent on different items or what different departments
spent. They work best with smaller numbers of values, about half a dozen; more than this and the 
visual impact begins to fade.

As the Chart Wizard guesses the series that you wish to include in your pie chart, you might need 
to adjust this initially on the Data Ranges page of the Wizard if you know you want a pie chart, or 
by using the Format > Data Ranges > Data Series dialog.

You can do some interesting things with a pie chart, especially if you make it into a 3D chart. It can 
then be tilted, given shadows, and generally turned into a work of art. Just do not clutter it so much 
that your message is lost, and be careful that tilting does not distort the relative size of the 
segments.

You can choose in the Chart Wizard to explode the pie chart, but this is an all or nothing option. If 
your aim is to accentuate one piece of the pie, you can separate out one piece by carefully 
highlighting it after you have finished with the Chart Wizard, and dragging it out of the group. When
you do this you might need to enlarge the chart area again to regain the original size of the pieces.

Figure 25: Pie chart examples

The effects achieved in Figure 25 are explained below.

• 2D pie chart with one part of the pie exploded: Select Insert > Legend and deselect the 
Display legend box. Select Insert > Data Labels and select Show value as number. Then 

carefully select the piece you wish to highlight, move the cursor to the edge of the piece 
and click (the piece will have highlight squares to mark it), and then drag it out from the rest
of the pieces. The pieces will decrease in size, so you need to highlight the chart wall and 
drag it at a corner to increase the size.

• 3D pie chart with realistic schema and illumination: Select Format > 3D view > 
Illumination where you can change the direction of the light, the color of the ambient light, 
and the depth of the shade. Also adjusted is the 3D angle of the disc in the Perspective 
dialog on the same set of tabs.

The chart updates as you make changes, so you can immediately see the effects.

If you want to separate out one of the pieces, click on it carefully; you should see a wire 
frame highlight. Drag it out with the mouse and then, if necessary, increase the size of the 
chart wall.

• 3D pie chart with different fill effects in each portion of the pie: Select Insert > Data labels 
and select Show value as percentage. Then carefully select each of the pieces so that it 
has a wire frame highlight and right-click to get the object properties dialog; choose the 
Area tab. For one we selected a bitmap, for another a gradient and for the third we used 
the Transparency tab and adjusted the transparency to 50%.
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• Donut charts shown in Figure 26 are subtypes of the pie chart. To create one, select Pie in 
the Chart Wizard dialog, and select the third or fourth type of pie chart. For more variety, 
use a 3D Look.

Figure 26: Donut chart examples

Area charts

An area chart shows values as points on the Y-axis and the X-axis shows categories. The Y values
of each data series are connected by a line and the area between lines is filled with a color. The 
focus of an area chart is to emphasize the changes from one category to the next.

• Normal – this subtype plots all values as absolute Y values. It first plots the area of the last 
column in the data range, then the next to last, and so on, and finally the first column of 
data is drawn. Thus, if the values in the first column are higher than other values, the last 
drawn area will hide the other areas.

• Stacked – this subtypes plots values cumulatively stacked on each other. It ensures that all
values are visible, and no data set is hidden by others. However, the Y values no longer 
represent absolute values, except for the last column which is drawn at the bottom of the 
stacked areas.

• Percent – this subtype plots values cumulatively stacked on each other and scaled as 
percentage of the category total.

An area chart is a version of a line or column graph. It may be useful where you wish to emphasize
volume of change. Area charts have a greater visual impact than a line chart, but the data you use 
will make a difference.

Figure 27: Area chart examples – the good, the bad, and the ugly
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As shown in Figure 27, an area chart is sometimes tricky to use. This may be one good reason to 
use transparency values in an area chart. After setting up the basic chart using the Chart Wizard, 
do this:

1) Right-click on the Y axis and select Delete Major Grid from the context menu. As the data 
overlaps, some of it is missing behind the first data series, as shown in the example on the 
left. This is not what you want. A better solution is shown in the center example.

2) After deselecting the Y axis grid, right-click on each data series in turn and select Format 
Data Series. On the Transparency tab, set Transparency to 50%. The transparency makes 
it easy to see the data hidden behind the first data series. Now, right-click on the X axis and
select Format Axis. On the Label tab, select Tile in the Order section and set the Text 
orientation to 55 degrees. This places the long labels at an angle.

3) To create the example on the right, after doing the steps above, right-click and select Chart
Type. Select the 3D Look option and select Realistic from the drop-down list. We also 
twisted the chart area around and gave the chart wall a picture of the sky. As you can see, 
the legend turns into labels on the z-axis. Overall, although it is visually more appealing, it 
is more difficult to see the point you are trying to make with the data.

Other ways of visualizing the same data series are represented by the stacked area chart or the 
percentage stacked area chart (Figure 28). In the first, each number of each series is added to the 
others so that it shows an overall volume, but not a comparison of the data. The percentage 
stacked chart shows each value in the series as a part of the whole. For example in June all three 
values are added together and that number represents 100%. The individual values are a 
percentage of that. Many charts have varieties which have this option.

Figure 28: Examples of stacked and percentage stacked area charts

Line charts

A line chart is a time series with a progression. It is ideal for raw data and useful for charts with 
plentiful data that show trends or changes over time where you want to emphasize continuity. On 
line charts, the X-axis is ideal to represent time series data.

A line chart shows values as points on the Y-axis and the X-axis shows categories. The Y values of
each data series can be connected by a line.

• Points only – this subtype plots only points.

• Points and lines – this subtype plots points and connects points of the same data series 
by a line.

• Lines only – this subtype plots only lines.

• 3D lines – this subtype connects points of the same data series by a 3D line.
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Select Stack series to arrange the points for Y values cumulative above each other. The Y values 
no longer represent absolute values, except for the first column which is drawn at the bottom of the
stacked points. If you select Percent, the Y values are scaled as percentage of the category total.

Select Smooth lines to draw curves through the points instead of straight lines. Click Properties 
for a dialog to change the curve properties.

Things to do with lines: thicken them, make them 3D, smooth the contours, just use points. 
However, 3D lines can confuse the viewer, so just using a thicker line often works better.

Figure 29: Line chart examples

Scatter or XY charts

XY (Scatter)

An XY chart in its basic form is based on one data series consisting of a name, a list of X-values, 
and a list of Y-values. Each value pair (X & Y) is shown as a point in a coordinate system. The 
name of the data series is associated with the Y-values and shown in the legend.

When creating an XY chart refer to the following example tasks. Your XY chart may have more 
than one data series.

• Scale the X-axis.

• Generate a parameter curve, for example a spiral.

• Draw the graph of a function.

• Explore the statistical association of quantitative variables

XY chart variants

You can select an XY chart variant on the first page of the Chart Wizard, or by choosing Format > 
Chart Type for a chart in edit mode.

The chart is created with default settings. After the chart is finished, you can edit its properties to 
change the appearance. Line styles and icons can be changed on the Line page of the data series
properties dialog.

Double-click any data point to open the Data Series dialog. In this dialog, you can change many 
properties of the data series.

For 2D charts, you can select Insert > Y Error Bars to enable the display of error bars.

You can enable the display of mean value lines and trend lines using commands on the Insert 
menu.
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• Points only – each data point is shown by an icon. Calc uses default icons with different 
forms and colors for each data series. The default colors are set in Tools > Options > 
Charts > Default Colors.

• Lines Only – this variant draws straight lines from one data point to the next. The data 
points are not shown by icons. The drawing order is the same as the order in the data 
series. Mark Sort by X Values to draw the lines in the order of the X values. This sorting 
applies only to the chart, not to the data in the table.

• Points and Lines – this variant shows points and lines at the same time.

• 3D Lines – the lines are shown like tapes. The data points are not shown by icons. In the 
finished chart select 3D View to set properties like illumination and angle of view.

• Smooth Lines

– Mark Smooth Lines to draw curves instead of straight line segments.

– Click Properties to set details for the curves.

– Cubic Spline interpolates your data points with polynomials of degree 3. The 
transitions between the polynomial pieces are smooth, having the same slope and 
curvature.

– The Resolution determines how many line segments are calculated to draw a piece of 
polynomial between two data points. You can see the intermediate points if you click 
any data point.

– B-Spline uses a parametric, interpolating B-spline curve. Those curves are built 
piecewise from polynomials. The Degree of polynomials sets the degree of these 
polynomials.

Example of XY chart

Scatter charts are great for visualizing data that you have not had time to analyze and they may be
the best for data when you have a constant value against which to compare the data; for example, 
weather data, reactions under different acidity levels, conditions at altitude, or any data which 
matches two series of numeric data. In contrast to line charts, the X-axis are the left to right labels, 
which usually indicate a time series.

Figure 30: XY (Scatter) chart example
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Scatter charts may surprise those unfamiliar with how they work. While constructing the 
chart, if you choose Data Range > Data series in rows, the first row of data represents 
the X-axis. The rest of the rows of data are then compared against the first row data.
Figure 30 shows a comparison of three currencies with the Japanese Yen. Even though 
the table presents the monthly series, the chart does not. In fact the Japanese Yen does 
not appear; it is merely used as the constant series that all the other data series are 
compared against.

Bubble charts

A bubble chart is a specific variation of a scatter chart in which the data points are replaced with 
bubbles showing the relations of three variables. Bubble charts are often used to present financial 
data or social/demographic data. It shows the relations of three variables in two dimensions. Two 
variables are used for the position on the X-axis and Y-axis, while the third is shown as the relative 
size of each bubble. One or more data series can be included in a single chart.

The data series dialog for a bubble chart has an entry to define the data range for the bubbles and 
their sizes. 

It is sometimes easier to build a bubble chart manually in the data range entry section of the chart 
wizard. In the example chart shown in Figure 31, the range including the dates and the three series
was highlighted before starting the chart wizard. If you do not include the top row with the dates, 
there is no way to include this data as a category later. 

The names of the series were added manually, as were the ranges for the second and third series. 

Each data series was highlighted and the data points added and formatted to be in the center of 
the data point. In this case the number (which is the “dimension”) was deselected and category 
(the year) selected. The data points are formatted using the transparency tab with a radial gradient.

Figure 31: Bubble chart example

Note
If the data series for X-axis contains text, an order number will be displayed in the 
labels of this axis. Otherwise, the data of the series will be used for the X-axis, which 
can lead to irregularly arranged bubbles.
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Net charts

A net chart is similar to a polar or radar chart and displays data values as points connected by 
some lines in a grid net that resembles a spider net or a radar tube display.

For each row of chart data, a radial is shown on which the data is plotted. All data values are 
shown with the same scale, so all data values should have about the same magnitude.

A net chart is useful for comparing data that are not time series, but show different circumstances, 
such as variables in a scientific experiment or direction. The poles of the net chart are equivalent to
the Y-axes of other charts. Generally, between three and eight axes are best; any more and this 
type of chart becomes confusing. Before and after values can be plotted on the same chart, or 
perhaps expected and real results, so that differences can be compared.

Figure 32: Net chart examples

Figure 33: Example of filled net or radar chart

Figure 32 shows example of two types of net charts:

• The left example is a plain net chart without grids and with just points, no lines.

• The right example is a net chart with lines, points and grid. Axes colors and labels changed.
Chart area color = gradient. Points changed to 3D ones.

Other varieties of net chart show the data series as stacked numbers or stacked percentages. The 
series can also be filled with a color as shown in Figure 33. Partial transparency is often best for 
showing all the series.
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Stock charts

A stock chart illustrates the market trend for stock and shares by giving opening price, bottom 
price, top price and closing price. The transaction volume can also be shown and the X-axis can 
represent a time series.

When you set up a stock chart in the Chart Wizard, the Data Series dialog is very important. The 
data should be arranged as shown in the example table below because you need to tell it which 
series is for the opening price, closing price, high and low price of the stock, and so on.

Transaction
volume

Opening price
Low (bottom

price)
High (top price) Closing price

Monday 2500 20 15 25 17

Tuesday 3500 32 22 37 30

Wednesday 1000 15 15 17 17

Thursday 2200 40 30 47 35

Friday 4600 27 20 32 31

The open, low, high, and closing values of a row build together one data unit in the chart. A stock 
price data series consists of several rows containing such data units. The column containing the 
transaction volume builds an optional second data series.

Depending on the chosen variant, you may not need all columns.

Stock chart variants

Select a stock chart type on the first page of the Chart wizard and then select one of the four 
variants.

• Type 1 – based on low and high column, Type 1 shows the distance between bottom price 
(low) and top price (high) by a vertical line. Based on the low, high, and close columns, 
Type 1 shows an additional horizontal mark for the closing price.

• Type 2 – based on the open, low, high, and close columns, Type 2 generates the traditional
candle stick chart. Type 2 draws the vertical line between the bottom and top price and 
adds a rectangle in front, which visualizes the range between the opening and closing 
price. If you click on the rectangle, you see more information in the status bar. Calc uses 
different fill colors for rising values (the opening price is lower than the closing price) and 
falling values.

• Type 3 – based on the volume, low, high, and close columns, Type 3 draws a chart like 
Type 1 with additional columns for the transaction volume.

• Type 4 – based on all five data columns (volume, open, low, high, and close), Type 4 
combines a chart of Type 2 with a column chart for the transaction volume.

Note
If measurement for transaction volume is in units, a second Y axis is introduced in 
chart Type 3 and Type 4. The price axis is shown on the right side and the volume 
axis on the left side.

Setting data source

You can select or alter a data range on the second page of the Chart wizard or in the Data Range 
dialog. For fine tuning use the Data Series dialog.
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To specify a data range do one of the following:

• Enter the data range in the text box.

An example data range would be "$Sheet1.$B$3:$B$14". Note that a data range may 
consist of more than one region in a spreadsheet, for example 
"$Sheet1.A1:A5;$Sheet1.D1:D5" is also a valid data range.

If the syntax is not correct, Calc shows the text in red.

• Click Select data range to minimize the dialog, then drag to select the data range. When 
you release the mouse, the data are entered. Click Select data range again to add a data 
range. In the input field of the minimized dialog, click after the entry and type a semicolon. 
Then drag to select the next range.

• Click one of the options for data series in rows or in columns.

Your stock chart data are in columns, if the information in a row belongs to the same candle stick.

Organize data series

In the data series area on the left side of the dialog, you can organize the data series of the actual 
chart. A stock chart has at least one data series containing the prices. It might have a second data 
series for transaction volume.

If you have more than one price data series, use the Up and Down arrow buttons to order them. 
The order determines the arrangement in the chart. Do the same for volume data series. You 
cannot switch price and volume data series.

To remove a data series, select the data series in the list and click Remove.

To add a data series, select one of the existing data series and click Add. You get an empty entry 
below the selected one, which has the same type. If you have no price data series or no volume 
data series, you must first select a range for these series in the Data Range dialog.

Setting data ranges

In the Data Ranges dialog you can set or change the data range of each component of the 
selected data series.

The upper list shows the role name of the components and the current values. When you have 
selected a role, you can change the value in the text box below the list. The label shows the 
selected role.

Enter the range into the text box or click on Select data range to minimize the dialog and select 
the range with the mouse.

Select Open Values, Close Values, High Values, and Low Values in any order. Specify only the 
ranges for those roles which you need for the chosen variant of the stock chart. The ranges need 
not be next to each other in the table.

Legend

The legend displays the labels from the first row or column or from the special range that you have 
set in the Data Series dialog. If your chart does not contain labels, the legend displays text like 
"Row 1, Row 2, ...", or "Column A, Column B, ..." according to the row number or column letter of 
the chart data.

The legend shows the value from the range, which you entered in the Range for Name field in the 
Data Range dialog. The default entry is the column header of the closing price column.

Select one of the position options. When the chart is finished, you can specify other positions using
the Format menu.
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Column and line charts

A column and line chart is a combination of two other chart types. It is useful for combining two 
distinct but related data series, for example sales over time (column) and the profit margin trends 
(line).

• Columns and Lines – the rectangles of the column data series are drawn side by side so 
that you can easily compare their values.

• Stacked Columns and Lines – the rectangles of the column data series are drawn 
stacked above each other, so that the height of a column visualizes the sum of the data 
values.

The example chart in Figure 34 has manufacturing cost and profit data for two products over a 
period of time (six months in 2007). To create this chart, first highlight the table of data and start the
Chart Wizard. Choose the Column and Line chart type with two lines and the data series in rows. 
Then give it a title to highlight the aspect you want to show. The lines are different colors at this 
stage and do not reflect the product relationships. When you finish with the Chart Wizard, highlight 
the chart, click on the line, right-click and select Format Data Series.

There are a few things to change: The colors should match the products. So both Ark 
Manufacturing and profit are blue and Prall is red. The lines need to be more noticeable, so make 
the lines thicker by increasing the width to 0.08.

For the background, highlight the chart wall, right-click and select Format Wall. On the Area page, 
change the drop-down box to show Gradient. Choose one of the preset gradient patterns and 
make it lighter by going to the Transparency tab and making the gradient 50% transparent.

To make the chart look cleaner without the grid, go to Insert > Grids and deselect the X-axis 
option.

Figure 34: Column and line chart example
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