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SOFTWARE LICENSE AGREEMENT 
 

Carefully read all the terms and conditions of this Agreement prior to installing software.  Do not 
activate this software until you have read this entire Agreement.  Installing this software indicates 
your acceptance of these terms and conditions. 

 
If you do not agree to these terms and conditions, then return the software and other components 
of the software package of this product to the place of purchase and your money will be refunded.  
If you downloaded this software in its demonstration form and you do not agree to the terms of 
the license, you may retain the software only in its demonstration form solely for the purpose of 
passing on the demonstration software to another prospective buyer.  No refunds will be given for 
products downloaded off of the Internet that have been registered and activated. 

 
1. LICENSE: You are granted a personal, nontransferable, and nonexclusive, license to use 

the enclosed software, under the terms stated in this Agreement.  Title, copyright and 
ownership of the software and any and all related documentation remains with Rockton 
Software, Inc (Rockton Software).  This software and related programs may be used only 
on a single site licensed for use of Microsoft Dynamics GP, for the number of concurrent 
users as provided for in the original Microsoft Dynamics GP Software registration and 
purchase.  Registration keys can be obtained directly from Rockton Software, if 
applicable.  You may not distribute copies of the registered and activated software or any 
of the associated documentation to others.  The demonstration version of the software 
may be distributed freely.  You may not modify, reverse engineer, de-compile, 
disassemble or translate the software or related documentation without the prior written 
consent of Rockton Software, Inc. 

2. BACKUP: You may make backup copies of this software solely for your own use.  You 
must reproduce and include the copyright notice on the backup copies.  If all or any 
portion of this software is included in other software packages, then the copyright notice 
must appear on these other materials. 

3. TRANSFER: You may not transfer this software to any other party.  There are no 
provisions whatsoever for any other transfer, operation, or use of the software by any 
other party whatsoever except for the original buyer of the product that has been 
registered with the Rockton Software at the time of original purchase and software 
activation. 

4. LIMITED WARRANTY: Rockton Software warrants for a period of thirty days (30 days) 
from the date of receipt, that the software covered by this agreement will perform 
substantially in accordance with the accompanying written documentation.  You assume 
the entire risk as to the results and performance of the software.  This warranty gives you 
specific legal rights and you may also have other rights that vary from state to state.  
Rockton Software makes no claim in regard to the merchantability or suitability for any 
specific purpose of this or any other software product. 

5. ACKNOWLEDGMENT: By activating, and using this product you acknowledge that you 
have read this agreement, understand it, and agree to be bound by its terms and 
conditions.  You also agree that this agreement is the complete and exclusive statement 
of agreement between the parties and supersedes all proposals or prior agreements, 
verbal or written, and any other communications between the parties relating to the 
subject matter of this agreement. 

6. REMEDIES: Rockton Software's entire liability and your exclusive remedy shall be at the 
option of Rockton Software, either (a) return of price paid or (b) repair or replacement of 
the software that does not meet the limited warranty and is returned to Rockton Software.  
If you have need of service or help regarding this software, you should contact the dealer 
through which the software was originally purchased.  There is no obligation to render 
assistance to you if you are not the owner under which the software is registered, or if the 
registered user has not purchased a recognized support plan from the vendor of this 
product.  The laws of the State of Idaho will govern this Agreement. 
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Introduction  
 
 
Rockton Software is pleased to bring Auditor with E-Sign to the Microsoft Dynamics GP 
community.   
 
Auditor is a system management tool to track data changes in your Dynamics GP 
accounting system.  Auditor answers Who changed What, When, Where, and optionally, 
Why.  Auditor can be configured to track field-level specific changes, when new records 
are added, and when information is deleted from your system. 
 
E-Sign gives you the ability to require approval for changes made to sensitive fields.  
The User making the change and the Approver “sign” that change by entering their 
Dynamics GP password.  Optionally, changes can be set to require a User’s signature 
without requiring approval. 
 
Auditor with E-Sign also works with all 3rd party installed products which integrate with 
Dynamics GP, as long as the products are Dexterity based. 
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What’s in This Manual 
 
 
This manual contains the basic instructions needed for the installation and use of 
Rockton Software’s Auditor with E-Sign.  You will find instructions for: 
 

• Installation 
• Navigation 
• Setting up Auditor 

 
If you do not find the information you need in the following documentation, please 
contact Rockton Software (see the following page).  
 
 
Symbols and Conventions 
 
To help you use this documentation more effectively, we have included the following 
symbols to highlight important information: 
 
 

���� 
This symbol points out suggestions and important notes 
that assist you in installing and using Auditor with E-Sign. 
 

���� 
The warning symbol alerts you to situations in which you 
should proceed with caution.  Notes highlighted with a 
warning symbol relate to information that affects your entire 
system—please read carefully!  
 

���� 
The “OK” symbol points out helpful tips that can simplify the 
process and save time.  
 

 
• Keyboard keys, specific buttons, file names and menu 
paths are shown in bold print, such as the Move Right 
button, the OK key or the setup.exe program.  

 
• Window titles and captions are shown in quotes, such as 
the “Maintenance” window. 
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Customer Technical Support 
 
 
Please contact your authorized reseller for support on this product.  Or, you can contact 
technical support at Rockton Software by phone at (877) 476-2586 or e-mail 
support@rocktonsoftware.com.  You can also visit www.rocktonsoftware.com for more 
information on Rockton products, including a Frequently Asked Questions section. 

 
User input into improving this product or constructive feedback is greatly appreciated. 
 
If you have registered your Rockton product, support is available depending on the 
support plan agreement you purchased.  Your first line of support should always be your 
Microsoft Business Solutions reseller. 
 
As always, technical ideas and user input is highly encouraged.  At Rockton, we want to 
hear your input.  So drop us a line whenever you feel like it.  Enjoy! 
 
 

mailto:support@rocktonsoftware.com
http://www.rocktonsoftware.com/
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System Requirements 
 
The system requirements for installing and using Auditor follow those of Microsoft 
Dynamics GP.  The following table lists the specific hardware and software 
requirements that pertain to Auditor: 

 

Operating system One of the following: 

• Windows Vista Business Edition, 
Ultimate Edition, or Enterprise 
Edition (32-bit or 64-bit) 

• Windows Vista Business Edition, 
Ultimate Edition, or Enterprise 
Edition with SP1 (32-bit or 64-bit) 

• Windows XP Professional SP2 (32-
bit or 64-bit) 

Processor Intel Pentium IV 2.4 gigahertz (GHz) or 
higher 

Available hard disk space 2 Meg in the Dynamics GP install folder; 5 
Meg in the DYNAMICS database 

Minimum available RAM 512 MB (1 gigabyte (GB) recommended) 

Microsoft SQL Server  One of the following: 
• SQL Server 2008 Standard Edition, 

Workgroup Edition, or Express 

Edition 

• SQL Server 2005 SP2 Standard 

Edition, Workgroup Edition, or 

Express Edition 

• SQL Server 2000 SP4 Standard 

Edition or Workgroup Edition 

• MSDE 2000 SP4 

 
Microsoft SQL Server Native Client 

Microsoft Dynamics GP One of the following: 

• Version 10 

• Version 10 with SP1 

• Version 10 with SP2 

• Version 10 with SP3 

Adobe Adobe 8.0, 7.0, or 6.0 
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Installation  

1. From the first computer you wish to install, copy the Audit.cnk file included in the 
downloaded or unzipped software into your local Dynamics GP installation folder. 

2. Include the new chunk file code into Dynamics GP by launching Dynamics GP.   

The following message will appear: “New code must be included in the 
DYNAMICS.SET dictionary.  Do you wish to include new code now?” Click Yes.   

This process will modify your DYNAMICS.SET file to include information relating 
to Auditor, and the Audit.cnk file will create a AUDIT.DIC file. 

This completes the installation process for each workstation. If this is the first workstation 
in your network on which you are installing Auditor, continue with the following section.  

First Workstation Instructions 

If this is the first workstation on which you are installing, complete the following steps.   

���� 

You will need to complete these steps only once for your system.  You do 
not need to perform these steps in each company.   
 

1. First, complete steps 1 thru 2 from the previous section. 

2. Log in as any User that has sufficient SQL Server rights to be able to create 
Tables and Triggers.  This user must either be in the ‘sysadmin’ fixed server role 
or the ‘db_owner’ role for the DYNAMICS database and any database for which 
there are SQL Table audits defined.  

3. Log into any company. Since Auditor maintains data at the system level, it is only 
necessary to install the software in one company. If you don’t have a registration 
key, we recommend that you log into the Dynamics GP lesson company.   

���� 

If you are evaluating the software and do not yet have a registration 
key, this product will only work in the Dynamics GP lesson company.  
To obtain a registration key, contact Rockton Software or your 
authorized reseller of Dynamics GP products. 

4. You will next be asked how you would like the Auditor windows to be accessed 
within the Dynamics GP menus.  A dialog will open with the following prompt: 

Where would you like Auditor's navigation to appear?  1) do not add Auditor to any menu; 
I will add it myself to the Navigation Pane, or 2) on the System menu, or 3) on the Utilities 
menu.  Choose "None" if you are unsure. 

The dialog will contain three buttons, labeled “None”, “System” and “Utilities”, 
corresponding to each of these three options, respectively.  Choose the 
navigation option that best suits your needs. 

5. Next, the Auditor Setup window will open and you will be prompted to install or 
upgrade. Select the Install/Upgrade option and click the Process button to launch 
the Install Progress dialog.  Press the Finish button to complete the install. 

6. If you do not yet have a registration key, you may skip this step. 

On the Auditor Setup window, choose Registration from the drop-down and click 
Process. The Auditor Registration window will open.  Carefully enter the 
Registration Key and press the OK Button. 

This completes the installation process for the first workstation.   
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Removing Auditor with E-Sign 

The following steps will completely remove Auditor from both workstation and server: 
 
1. Log in to Dynamics GP as any User that is either in the ‘sysadmin’ fixed server role 

or the ‘db_owner’ role for the DYNAMICS database and any database for which 
there are SQL Table audits defined. 

2. Open the Auditor Setup window and select Uninstall Auditor from the drop-down.  
Then click the Process button. 

3. Click OK on the message to close Dynamics GP. 
4. Delete the following files from the Dynamics GP installation directory (you may not 

find all of these files): 
AUDIT.DIC 
FRMS2704.DIC 
RPTS2704.DIC 
Auditor ReadMe.txt 
Auditor Manual.pdf 
Audit.cnk 

Manually uninstalling 

The following steps can also be used to manually remove Auditor with E-Sign: 

Manually uninstalling from a Workstation 

Perform this process on each workstation where you want to remove Auditor with E-
Sign. 

1. Edit the Dynamics.set file (located in the Dynamics GP installation directory) to 
remove the Auditor entries.  There are three steps to this: 

a. The first line in the file should be a number.  Subtract 1 from this number. 
b. Remove these two lines: 

2704 
Auditor 

c. The bottom part of the file contains several path names.  Remove the ones that 
reference the following dictionaries: 

AUDIT.DIC 
FRMS2704.DIC 
RPTS2704.DIC 

2. Perform step 4, above to remove files from the Dynamics GP installation directory. 

Manually uninstalling from the Server 

Perform this process only if you want to completely remove Auditor with E-Sign from the 
system. 

1. Open SQL Enterprise Manager. 
2. Drop all tables in the DYNAMICS database that are named RSAxx, where xx is the 

table number. 
3. Drop all stored procedures in the DYNAMICS database whose names start with 

zDP_RSAxxYYY, where xx is the table number. 
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Navigation  
 
 
Because Auditor with E-Sign is designed to be an administrative tool, Auditor windows 
will only appear on the Dynamics GP menus if you are logged in as ‘sa’ or ‘DYNSA’.  
With the exception of the system administrator, it is unnecessary for users to navigate to 
any features of Auditor.   
 
When you install Auditor with E-Sign, you will be offered three options from which to 
access its windows.  You can choose to install on the System Setup menu, or the 
Utilities menu, or not to install to any menus at all.  If you choose the latter option, you 
can add any window to the Shortcut Bar using the procedure described below: 
 

• Open the Shortcut Bar 

• From the Shortcut Bar, press the Add button.  Choose Other Window… from 
the drop down.  

• Select Auditor in the Add Window Shortcut window.  Navigate to the window that 
you want to access and then press the Add button. 

• Press the Done button. 

 

Backup and Restore 
 

All Auditor Setup data is stored in the DYNAMICS database.  Therefore, whatever 
process you normally use to backup this database will also automatically backup all 
Auditor Setup data.  Similarly, restoring this database will restore Auditor data as well. 

In addition to the Setup data, there may be some SQL Triggers on other databases.  
These would only be present if you have chosen to define SQL Table Audits on tables in 
databases other than the DYNAMICS database.  If you have chosen to do this, then you 
should backup those databases as well. 
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An Overview of Auditor 

Auditor has three methods for tracking data changes in Dynamics GP: by Window, by 
Table and by SQL Table.  The Window method is the easiest to use, while the Table and 
SQL Table methods are more technical in nature.  Try auditing your system using the 
Window method first.  If you cannot accomplish your auditing goals from the Window 
method, then try the Table or SQL Table method.  At any time you can contact Rockton 
Software or your reseller for assistance. 

The Window method allows you to “point and click” on different screens or windows in 
Dynamics GP.  By using a wizard, you can simply open a window and click on the fields 
you wish to audit.  Auditor will collect the technical information for you, and begin 
auditing your selections. 

The Table method allows database administrators to monitor table operations in 
Dynamics GP.  When a record is added, deleted, or modified, you can track who 
changed what on the record.  An understanding of database structures in recommended 
for using this method. 

The SQL Table method also allows database administrators to monitor table operations 
in Dynamics GP.  However, in addition to auditing Dynamics GP tables, you can also 
audit Inserts, Updates and Deletes that occur in any table in any database on the SQL 
Server instance where Dynamics GP and Auditor are currently installed. 

All audits are tracked by a Record Key, which is usually the primary piece of information 
that tracks what has changed.  For instance, if you are auditing employee information 
from the Payroll setup window, the Employee ID would be the Record Key.  If the 
Employee Name changed, you would want to know for which employee the name 
changed, and that would be indicated by the Record Key.  You can choose which fields 
on a window or table to use for the Record Key.  However, for tables, only the fields in 
the Primary Key will be included as part of the Record Key field in the Audit Log 

For Table and SQL Table Audits, you can optionally select additional “reference” fields to 
show on a particular Audit.  For instance, when adding or deleting an Employee record 
you might want to display the Employee’s full name and Social Security Number.  Any 
field in the table being audited can be selected as a Reference Field. 

An audit is a logging of a change.  When a field changes, you can either “Audit” that field 
or you can “Audit with Note”.  Notes are helpful when you want users to explain why they 
made a data change.  For instance, if you are auditing employee information, such as 
name, address, and status, you may want to use an audit for name and address fields, 
but place an Audit with Note option on the Department field.  By doing this, when a user 
changes the Department field for an employee, they will be required to enter a note 
explaining the reason for the change.  Notes will be tracked as part of the audit. 

You may be tempted to audit everything in your system.  This is not recommended.  
Carefully review the reasons why you want to audit data, and what, specifically, you 
want to audit.  Because an audit is created for every field change (except for the Table 
method) the audit log can grow very large very fast.  An extremely lengthy audit log 
which tracks everything is often useless to anyone. 
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Performance Issues with Auditing 
 
 
Because Auditor has the ability to track so much information, you may want to consider 
that you might encounter performance limitations when using Auditor. 
 
In general, auditing by the Window method shows a non-noticeable effect on 
performance and speed.  Because auditing is done real-time, a small amount of 
processing occurs each time a user enters and exits a field.  Only a very fast typist who 
changes several fields in rapid succession would notice any performance degradation, 
and this is highly unlikely to be noticed at all.   
 
When auditing using the Table or SQL Table methods, it is unlikely that you will 
experience performance degradation unless using a batch process.  If you are auditing a 
table where users are editing one record at a time using data entry screens, the effect is 
not noticeable.  However, if you are posting a batch of transactions, and auditing each 
record, you may notice a slight delay in processing.  For instance, if you are auditing 
deletes on unposted receivables transactions, and you post a batch of 100 transactions, 
a normal processing time of 30 seconds may be increased to 32 seconds.  Again, the 
effect is usually not noticeable, but as the scale of auditing increases you may 
experience a slight degradation in performance.   
 
Most administrative users of Auditor feel the slight performance hit offsets the value of 
the information being collected.  Again, as mentioned above, it is recommended that you 
carefully choose what you want to audit and not simply “audit everything”.  There is a 
performance cost for auditing in any audit system, and you may want to monitor certain 
audits to determine if their speed is acceptable.  In general, performance degradation 
will not be an issue for most users of Auditor. 
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About Auditor window 
 
 

 
 

 
This window is accessible in one of these ways, depending upon what you opted when you first 
installed Auditor: 

• From the Shortcut Bar. 

• Go to Help > About Microsoft Dynamics GP.  From the Extras menu, choose Additional > 
About Auditor. 

• Go to Tools > Utilities > About Auditor 
 

 
Description 
 

The About Auditor window shows the version of Auditor that you have loaded, along with 
the phone number to use to contact Rockton Software, and a link to our website.  In 
addition, it also provides a convenient means of navigating to the Auditor Registration 
window. 
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Auditor Registration window 
 

 
 

This window is accessible in one of these ways, depending upon what you opted when you first 
installed Auditor: 

• From the Shortcut Bar. 

• Go to Help > About Microsoft Dynamics GP…  From the Extras menu, choose Additional 
> About Auditor.  Then choose the Register button. 

• Log on as the System Administrator (‘sa’) and go to Tools > Setup > Auditor > Auditor 
Setup.  From the drop-down, choose Registration and choose the Process button. 

• Log on as the System Administrator (‘sa’) and go to Tools > Utilities > Auditor Setup.  
From the drop-down, choose Registration and choose the Process button. 

 
 
Description 
 
The Auditor Registration window is where you enter your Registration Key.  After 
entering your key, just tab off the Registration Key field.  If your key is valid, a “Thank 
You” message will be displayed.  If not, you will see the words Key is Invalid to the right 
of the Expiration Date.   
 
If you your key is invalid, first verify that you have not mistyped anything.  If you received 
your keys in an email, it may be helpful to copy the keys from the email and paste them 
into the Registration Key field to avoid typing mistakes.  If you still see this message, 
contact Rockton Support to verify that your Site Name, User Count and Dynamics GP 
version have not changed since you got your keys.  If necessary we will generate new 
keys and resend them to you. 
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Register Rockton Products window 

 

This window opens upon exiting the Dynamics GP Registration window if any Rockton products 
are not properly registered. 

Description 

Whenever you close the Dynamics GP Registration window, the registration keys for all 
Rockton products that you have installed will be verified.  If any are found to be invalid 
(for instance, because the User Count or Site Name has changed since the last time the 
Rockton keys were updated), then this window will open automatically.  The box in the 
center of the window will list each Rockton product that requires new registration keys, 

To correct this situation, first contact Rockton Software to obtain new keys for the 
products listed.  One convenient way to do this is to check the Request Reg Keys box 

for each product that requires new keys, then click the Email button ( ).  This will send 
an email with your request to Rockton Software.  Note that you must have Microsoft 
Outlook configured on the computer where you are sending this email. 

Once you have your new Registration Keys you can enter them by double-clicking each 
product in the list above.  This will open the Registration window for that product.  
Alternatively, you can print a list of the products displayed by clicking the Print button, 
then use this list to update the keys for each product at a later time. 
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Auditor Setup window 
 
The Auditor Setup window allows you to perform setup and maintenance tasks. 

 
 

This window is accessible in one of these ways, depending upon what you opted when you first 
installed Auditor: 

• From the Shortcut Bar. 
• Log on as Sys Admin (‘sa’) and go to Tools > Setup > Auditor > Auditor Setup.   
• Log on as Sys Admin (‘sa’) and go to Tools > Utilities > Auditor Setup.   

Description 

The task drop-down is used to select which task you want to perform.  Once you have 
selected a task, choose the Process button.  The tasks available are described below: 

Install/Upgrade Auditor Installs or upgrades from a previous version.  It also 
installs Smartlist objects, and will set table permissions 
to all users in the system database.  You can perform 
this task multiple times. 
Note: you must be logged in as a User that is in the 
‘sysadmin’ fixed server role or the ‘db_owner’ role for the 
DYNAMICS database and any database for which there 
are SQL Table audits defined. 

Registration Opens the window where you enter the registration key. 
Add Smartlist Objects If you have removed the Audits and E-sign Approvals 

objects from SmartList, you can add them back by 
performing this task. 

Remove Smartlist Objects Removes the Audits and E-Sign Approvals objects from 
SmartList. 

System Settings Opens the window where System Administrators and 
other system settings are managed. 

Integrity Check Run this process to verify the integrity of your audit 
setups.  A report will inform you of any discrepancies. 

Audit Log Maintenance Opens the purge utility to maintain your system audit log. 
Approval  Log Maintenance Opens the purge utility to maintain the Approval log. 
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Rebuild SQL Triggers Drops and re-creates all SQL Triggers associated with 
SQL Table audits that you have defined. 
Note: you must be logged in as a User that is in the 
‘sysadmin’ fixed server role or the ‘db_owner’ role for 
any database for which there are SQL Table audits 
defined. 

Rebuild SQL Tables Master Opens a window that allows you to recreate the list of 
tables and databases in the SQL Tables lookup on the 
Groups Maintenance window.  From this window you 
can recreate the entire list from scratch, add only newly 
added databases and tables to the list, or add 
information for a specified database to the list. 
Note: only the databases to which your User ID has 
access will be added to this list. 

Move Auditor to First 
Position 

Moves Auditor to immediately after Dynamics GP in the 
Launch File. 

Remove Auditor from the 
Launch File 

Removes Auditor from the Launch File.  This can be 
useful when troubleshooting.   

Auditor Debugger Rockton tech support may ask you to go to this window. 
Uninstall Auditor Tables will be removed from the database, the Audits 

object will be removed from Smartlist, and Auditor will be 
removed from the launch file. 

 

Clicking the “Check RocktonSoftware.com for updates” link will take you to the 
Downloads web page for this product.  Here you can verify that you are installing the 
latest build. 
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Please Wait window 

 

 

 
 

 
This window opens automatically after you log into a Company in Dynamics GP.  
 

Description 

The Please Wait window opens automatically if you attempt to open any windows before 
Auditor has been fully initialized.  Its purpose is to prevent users from doing anything in 
the system that might not otherwise be audited because Auditor is not yet fully active.  
As long as this window is open, a user cannot do anything in Dynamics GP.  Once 
Auditor’s initialization has completed, this window will close automatically. 

You may find that the Please Wait window opens shortly after you log in to a Dynamics 
GP Company, even though you have not attempted to open any windows.  This will 
happen if your system is configured to automatically open any windows on the login (for 
example, the Reminders window).  Once Auditor is through initializing, the Please Wait 
window will close. 
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Group Maintenance window 
 

 

How you access this window depends upon what you opted when you installed Auditor: 

• From the Shortcut Bar. 

• Log on as Sys Admin (‘sa’) and go to Tools > Setup > Auditor > Auditor Groups.   

• Log on as Sys Admin (‘sa’) and go to Tools > Utilities > Auditor Groups.   

Description 

You may want to have a Group for Receivables, and another for Payables.  You can 
have an unlimited number of Forms or Tables in a Group.  Once a Group is configured, it 
can be exported to a text file to be sent to another site to be Imported using this window.   

Use the Add , Edit and Delete buttons to modify the Forms or Tables for a group. 

The Companies and Users features limit audits in this Group to specific companies or 
users.  By default, a new Group will work for all companies and all users.  Also, 
Company and User information is NOT imported or exported.  

A given Table or Form can belong to one and only one Group.  Therefore, how a Form 
or Table is audited can only be set up one way across all companies and users. Auditing 
by SQL Table tracks changes in any table/database on the SQL server instance where 
Dynamics GP and Auditor are installed, including tables not related to Dynamics GP. 
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The Actions button has three items in its drop-list: Import Group, Export Group and 
Reconcile.  The Reconcile option opens the same Reconcile window that you can 
access from the Auditor Setup window.  The Import and Export options are described 
below. 

Exporting and Importing Audit Groups 

The Import Group and Export Group options on the Actions Button’s drop-list allow you 
to save Audit Groups that you have set up and then Import them at a later time, or on 
another system.   

To use the Export Group option, first enter or select an existing Audit Group on the 
Group Maintenance window.  Then go to Actions > Export Group.  This will open a 
dialog where you can choose where to save the exported Audit Group.  Once you have 
selected the location of the exported group, and the name of the export file, click the 
Save button.  Your group is now exported. 

Note: it is recommended that you keep the file extension as “.auditor” because 
this will help you find the Audit Group later when you attempt to import it.  The 
Import dialog looks for files of type “.auditor” by default. 

The Import Group option opens the Audit Group Import window, below. 

 

To import a previously exported Audit Group, first enter the Import File name and 
location, or select it by clicking on the Path button to the right of the Import File field.   

Next, decide if you want to import this group whether or not it has errors in it.  If you do, 
then mark the Allow Importing Groups with Errors check box.  Otherwise leave this 
option unmarked. 

Now click the Import button.  If the group you selected does contain errors, then parts of 
that group may not be imported, depending upon whether or not you selected the Allow 
Importing Groups with Errors option.  In either case, you will be given the option to view 
an error report.  Of course, if there are no errors, then the Audit Group will be imported 
normally. 
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Auditor Form Maintenance window 
 
Auditor Form Maintenance is where you select the fields that you want to audit, and how you 
want to audit them.  The fields are organized by window. 

 

 
 
To get to this window, first open the Group Maintenance window while you are logged on using 
the System Administrator (‘sa’) account.  Then double-click one of the forms listed in the Forms 
list box. 

 
Description 

A Form is a “container” for windows, and often a form contains one window with the 
same name as the form.  When you select a Window, its fields will list on the right side.  
By selecting a field, you can mark that field as a Key Field, Audit, or Audit with Note.  An 
icon will appear next to the field designating its purpose.  A field can not be audited if it is 
a Key Field.   

The easiest way to set up a window to be audited is by using the Field Selection Wizard, 
located at the lower left of the window.  Press this button to start the Wizard. 
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From the Wizard window, press Open Window to open the window you are Auditing. 

With this window is open, press the Key, Audit, or Audit w/Note buttons to enter the 
“mode” of field selection.  Once you are in a “mode”, click on the window fields you want 
to set to this mode, and they will automatically collect in the Wizard window. 

When you are finished, close the window.  Then press the Finish button on the Wizard.  

You can manually review which fields can be audited on a window by reviewing the list 
of fields on the right of the Auditor Form Maintenance window.  The tree to the left will 
list the form at the top, and all of its windows beneath it.  Selecting the form on the left 
will display all audited fields from all windows on this form on the right.  Selecting a 
window on the left will display all fields on that window to the right, whether or not they 
are part of an audit. 

You can choose useful options for each field that you audit.  Select a field in the right list, 
and then press the Field Options button.  The following window will appear: 
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The following Options are available for auditing. 
 
Notify the System 
Administrators 

Choose this option to send an email to each System 
Administrators email address (as specified in the 
System Setting setup window) or to update the 
Message Center. 

Send an Email to this Alternate 
Address 

Choose this option and specify an email address to 
send a specific person a notification of an audit on this 
field. 

Use an Alternate Display Field 
Name 

You can specify a more useful name for a field than 
what is defaulted in the system to appear in the Audit 
Log.  For instance, a field may be called “User Defined 
1” and in your setup that field may track “Customer 
Status”.  You can specify the alternate field name here 
and the Audit Log will show the alternate name 
instead. 

Add Decimal this Many Places 
from the Right 

Dynamics GP tracks currency fields with misleading 
decimal places.  For instance, $98.00 might be tracked 
as 9800 when audited.  By putting a 2 in this field, the 
9800 will be recorded as 98.00. 

Filter Predefined Notes to this 
Reason Group 

Once you have Reason Groups defined, you can 
assign a specific group to display in Note Entry for this 
audit field. 

Do Not Track Blank to Non-
Blank Changes 

It is sometimes useless to audit a field that changes 
from blank to a valid value, which often occurs when 
entering data for the first time.  Use this option to 
exclude audits of blank to non-blank values. 

Use Field Mapping Often times lists, radio buttons, or checkboxes appear 
as numbers instead of useful descriptions.  For 
instance, SOP Entry has an SOP Type that when 
audited appears as the numbers 1 through 5.  You can 
map the value “1” to “Quote” and “2” to “Order” so that 
the audit log reflects more useful data. 

Use Conditional Auditing Choose this option to make an audit conditional.  The 
condition listed must be true in order for an audit to 
occur.  Specify the comparison field, the operator 
(equal or not equal) and the string value to compare 
the field to.  If this expression evaluates to true during 
auditing, and audit will be captured. 
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Auditor Table Maintenance window 
 
Auditor Table Maintenance is where you select the fields that you want to audit, and how you 
want to audit them.  The fields are organized by table. 
  

 
 
To get to this window, first open the Group Maintenance window while you are logged on using 
the System Administrator (‘sa’) account.  Then double-click one of the tables listed in the Tables 
list box. 

 
 
Description 
 
You can select specific fields and/or table operations to audit.  For each field selected, 
you may specify the same options that are available for window fields.  The field list can 
be sorted by the column headings.   
 
For adds or deletions from the table, you may also specify these options, as well as 
requiring that the user enter a Note.  For changes to the table, you may specify that the 
audit will only take place after a certain amount of time has elapsed.   
 
All of these options are described in the tables below: 
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Option Explanation 

 

Track Added Record Check this option if you wish to audit when users add 
records to this table. 

Require Note If Track Added Record or Track Deleted Record is 
selected, you can require a Note to be entered for the 
user to explain why they added or deleted the record. 

Add/Delete Options On a table operation of Add or Delete, you can specify 
options on that audit, such as emailing a notification or 
specifying conditions on when to audit.  Pressing this 
button will open the same Field Options window that is 
used above in Form Maintenance.  Keep in mind some 
options are not valid for Additions and Deletions of 
records. 

Track Deleted Record Check this option to track deletions of records from this 
table. 

Track Edited Record Check this option to track specific field-level changes 
(which also must be selected in the field list below).  You 
can also optionally choose to track edits only after a 
certain number of hours of adding a new record.  This is 
useful in case you are not tracking new records, and it is 
likely that insignificant edits will be made in the first few 
hours of a new record being added. 

 

The following options are available for each field in the field list: 
 

Column Explanation 
 

Ref Use this column checkbox to mark “Reference Fields.”  Reference 
Fields are additional pieces of information that you want to see for 
each audit to help identify, or just provide more information about, 
the record being audited.  These fields will show up in the Audit 
Log for Adds, Edits and Deletes.  Note that the fields in the table’s 
Primary Key will always be Reference Fields. 

Audit Mark the fields for which you wish to track changes.  Only the fields 
marked will be audited. 

Note When a field is audited, you can optionally check the Note 
checkbox to force a user to explain why a field was changed.  
Users are prompted with note entry after they modify a record if 
this box is checked.  The user can close the note window, but they 
will be prompted repeatedly until they complete the notes. 

 
When you have completed specifying what to audit, click the OK button.  Auditor will now 
audit the tables and fields you have set up. 
 
Also, for any given field in the list, you can choose Field Options to set up advanced 
auditing features.  See the Field Options window as explained above with Form 
Maintenance for more details. 
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Auditor SQL Table Maintenance window 
 
Auditor SQL Table Maintenance is where you select the fields that you want to audit, and how 
you want to audit them.  The fields are organized by table. 
  

 
 
To get to this window, first open the Group Maintenance window while you are logged on using 
the System Administrator (‘sa’) account.  Then double-click one of the tables listed in the SQL 
Tables list box. 

 
 
Description 
 
You can select specific fields and/or table operations to audit.  You can also select 
whether or not you should audit if the user is changing a field from blank to some value.  
The field list can be sorted by the column headings.   
 
All of these options are described in the tables below: 
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Option Explanation 

 

Track Added Record Check this option if you wish to audit when users add 
records to this table. 

Track Deleted Record Check this option to track deletions of records from this 
table. 

Track Edited Record Check this option to track specific field-level changes 
(which also must be selected in the field list below). 

 

The following options are available for each field in the field list: 
 

Column Explanation 
 

Ref Use this column checkbox to mark “Reference Fields.”  Reference 
Fields are additional pieces of information that you want to see for 
each audit to help identify, or just provide more information about, 
the record being audited.  These fields will show up in the Audit 
Log for Adds, Edits and Deletes.  Note that the fields in the table’s 
Primary Key will always be Reference Fields. 

Audit Mark the fields for which you wish to track changes.  Only the fields 
marked will be audited. 

No Trk Blnk It is sometimes useless to audit a field that changes from blank to a 
valid value, which often occurs when entering data for the first 
time.  Use this option to exclude audits of blank to non-blank 
values. 

 
When you have completed specifying what to audit, click the OK button.  Auditor will now 
audit the tables and fields you have set up. 

Required Permissions to Create SQL Table Audits 

Your User ID must have sufficient rights to create database triggers on the SQL Server 
in order to complete the setup of a SQL Table audit.  This means that the User must be 
in the ‘sysadmin’ fixed server role or it must be in the ‘db_owner’ role for the database on 
which you are attempting to create the SQL Table audit.   

If you do not have sufficient rights to create the SQL trigger, then only the setup 
information will be saved (i.e. audits will not be logged).  To complete the SQL Table 
audit setup, log in as a User with the previously described rights and run the ‘Rebuild 
SQL Triggers’ process from the Auditor Setup window. 
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System Settings window  

The Auditor System Settings window allows you to manage System Administrators. 

 

This window is accessible in one of these ways, depending upon what you opted when you first 
installed Auditor: 

• From the Shortcut Bar. 
• Log on as System Admin (‘sa’) and go to Tools > Setup > Auditor > Auditor Setup.  Then 

choose System Settings and then the Process button. 
• Log on as System Admin (‘sa’) and go to Tools > Utilities > Auditor Setup.  From the 

drop-down, choose System Settings and choose the Process button. 

Description 

This window lets you specify which users in your system are System Administrators and 
which are E-Sign Approvers.  System Administrations (or “Sys Admins” for short) can 
optionally be notified in the Message Center or by Email when certain events occur.  E-
Sign Approvers are the only Users in the system that can approve or deny changes 
made to fields that have E-Sign Signatures assigned to them.  You can select multiple 
Sys Admins and E-Sign Approvers.  Also, it is OK for a User to be both. 
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Users that are Sys Admins can be notified when things of interest related to Auditor 
happen in the system.  There are two notification options for Sys Admins: Message 
Center and Email.  Selecting Message Center will add an item to the Auditor Message 
Center window for that Sys Admin.  Selecting Email will send an Email to the address 
specified for that Sys Admn.  Note that a MAPI-enabled email client such as 
Microsoft Outlook must be configured on the computer where the audit occurs for 
the email option to work. 

Notify options are described in the following table: 

 

Option Explanation 
 

Audit Notify When you set up an audit, you have the option of notifying the Sys 
Admins when that particular audit happens.  Selecting one of these 
options will notify this Sys Admin when these audits occur. 

Audit Log 
Maintenance 
Notify 

When the size of the Audit Log reaches the specified threshold, 
this Sys Admin will be notified.  This notification will be sent to the 
Message Center only once per day for this Sys Admin. 

Reg Key Notify If, for some reason, your Auditor Registration Keys become invalid 
(e.g. you GP User Count changes or you had temporary keys that 
expired), this Sys Admin will be notified.  This notification will be 
sent to the Message Center only once per day for this Sys Admin. 

 

Users that are E-Sign Approvers will be allowed to approve or deny changes made by 
other Users to fields that have a Signature assigned to them.  Specific Approvers can be 
assigned to individual Signatures as well.  The same notification options exist as for Sys 
Admins, 

Audit Log Maintenance Options 

If you check the “Warn System Administrators when log records exceed” checkbox, 
enter the number of records acceptable in the log file before being notified.  We 
recommend about 10,000 records to start with.  If this option is checked, then any user 
marked above as a System Administrator will, upon logging into Dynamics GP, receive a 
warning message notifying them that the log has exceeded this limit. 

Message Center Options 

Checking the “Warn System Administrators when Unread Messages exceed” check box 
will let you specify the number of unread messages there can be in the Message Center 
before the Sys Admins are notified.  If this option is checked, then any user marked 
above as a Sys Admin will, upon logging into Dynamics GP, receive a warning message 
notifying them that the Message Center has reached its unread message limit. 
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The “Open Message Center on login…” drop-down lists the options for when, or if, the 
Message Center should open after an Administrator logs into a Company.  Options are 
as follows: 

 

Option Explanation 
 

only when there 
are unread 
messages 

The Message Center window will open only if unread messages 
exist for the Auditor Administrator that is logging in. 

always The Message Center window will always open after an Auditor 
Administrator logs into a Company. 

never The Message Center window will not open after an Auditor 
Administrator logs into a company. 

 

Miscellaneous Options 

 “Allow editing of Audit Notes” lets users edit their notes in the Audit Inquiry window.  
Open the Audit Inquiry window from SmartList by double-clicking an audit.  By checking 
this box, users can edit their notes in the future rather than being limited to Note Entry.   

SQL Table Audit Options 

 “Do Not Encrypt SQL Triggers” may be used when working with Rockton Support.  
Under normal circumstances you will leave this box unchecked. 

“Do not allow SQL Table audits on non-GP databases” will cause the “Rebuild SQL 
Tables Master” process to exclude all databases except the DYNAMICS database and 
all company databases used by Great Plains.  These will then be the only databases 
that show up in the list when you attempt to add a SQL Table audit. 

“Do not allow SQL Table audits on SQL system databases” will cause the “Rebuild SQL 
Tables Master” process to exclude the master, model and msdb databases.  These 
databases will not show up in the list when you attempt to add a SQL Table audit. 

Tables in the tempdb database will always be excluded from this list and therefore will 
not be available for SQL Table audits. 

“Notify System Administrators for all SQL Table audits” controls whether or not a record 
is written to the Message Center for System Admins who have selected the Message 
Center Audit Notify option.  This option only applies to SQL Table audits, but it should be 
noted that it applies to ALL SQL Table audits.   
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Auditor Message Center window 
 
This is where Sys Admins and E-Sign Approvers are notified about system events.  

 

This window is accessible in one of these ways, depending upon what you opted when you first 
installed Auditor: 

• From the Shortcut Bar. 
• Log on as System Admin (‘sa’) and go to Tools > Setup > Auditor > Auditor > Message 

Center.  Then choose System Settings and then the Process button. 
• Log on as System Admin (‘sa’) and go to Tools > Utilities > Auditor > Message Center.  

From the drop-down, choose System Settings and choose the Process button. 

 
Description 

The Auditor Message Center shows all of the events that a Sys Admin or Approver has 
chosen to be notified about.  Messages listed can be sorted by any column by clicking 
on the column heading.  You can also limit which messages are displayed by selecting 
one of the Filters at the top of the window. 

The Date and Time fields indicate when then event referred to in the message occurred.  

The Type field is the Message Type.  It can have one of the following values: Audit, E-
Sign, Registration or Audit Log.   

User indicates the User that took the action that caused this notification to be sent.   

Company shows the name of the Company in which the action took place.  Company 
only applies to Audit and E-Sign messages since the other types are system-level 
events, not Company-specific ones. 
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You can see more information or take action on a particular message by double-clicking 
it.  The action taken when you double-click depends upon the Message Type: 

Message Type Action 
 

Audit Opens the Audit Inquiry window, where you can see details about 
the Audit selected. 

E-Sign Opens the Approval Inquiry window, where you can see details 
about a completed Approval.  Additionally, you can also approve or 
deny a Pending Approval, if you are the Approver. 

Audit Log Opens the Audit Log Maintenance window where you can archive 
and purge the Audit Log. 

Registration Opens the Auditor Registration window where you can enter or 
review the Registration Keys for Auditor. 

Messages that have not yet been read (by double-clicking them) will have a dot ( ) to 
the left of the Date column.  This is only for your reference and to give you the ability to 
filter by Read or Unread Messages.  You can also mark a group of messages as read or 
unread by clicking the Mark buttons ( ) at the upper-left of the message list.  A 

group of messages can be deleted by clicking the Delete button ( ) at the upper left of 
the message list. 

You can print a report of the messages displayed by clicking the Print button ().  The 
report generated will use whatever filters you have selected in the Message Center 
window. 
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Reason Codes window 
 

The Reason Codes window is where you set up common reasons for making system changes.  

 

This window is accessible in one of these ways, depending upon what you opted when you first 
installed Auditor: 

• From the Shortcut Bar. 
• Log on as Sys Admin (‘sa’) and go to Tools > Setup > Auditor > Auditor Reason Codes.   
• Log on as Sys Admin (‘sa’) and go to Tools > Utilities > Auditor Reason Codes. 

Description 

Reason Codes are predefined notes that are common reasons for making changes in 
the system.  For instance, changing an employee last name is often due to marriage or 
court decree.  You may want to preset the reasons in a list so users can quickly choose 
a reason during note entry without having to type it in. 

Reason Groups allow you to package several notes together and filter them on a specific 
audit.  For instance, you may have three reasons for a name change on employees, but 
you may have six reasons why a credit memo was issued.  The reasons that appear in 
one situation don’t make sense in another.  By grouping these two sets of reasons into 
two groups, you can make Note Entry and the E-Sign Approval process more useful by 
specific which Reason Group is to be used.  This is specified in the Options for a field 
audit.  When entering an audit note or requesting approval for a change, only those 
notes in the group which are related to that action will be listed. 

You can create a new group by pressing the New button to the right of the 
Reason Group field.  Likewise, you can delete a group by pressing the Delete button. 

Enter a reason in the Note/Reason box, and then Insert it into the list.  You can also 
highlight an entry in the list, then edit its text and press Replace.  Finally, you can 
remove a specific reason by highlighting it in the list and pressing the Remove button. 
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Note Entry window 

This window is where the User enters the reason for making any change in the system that has 
been set up to require a note. 

 

This window will open automatically whenever the User makes a change to a field that has been 
set to Audit w/ Note.  See the descriptions of the Auditor Form Maintenance and Auditor Table 
Maintenance windows above for more information about how to set up this type of audit. 

Description 

If you choose to audit a field and require a note, upon logging that audit the Note Entry 
window will appear.  It will specify the details of the change, and instruct the user, in 
bold, to enter the reason that they made the change. 

Pressing the Details button will show the Audit Inquiry window for more information. 

The user can enter a Note or Reason by typing in freeform text into the note field, or by 
choosing a predefined note from the drop down list.   

It is possible for users to press OK and not enter a note or reason as required.  
However, Auditor has a “nag” feature, and each time the user logs into Dynamics GP, 
un-noted audits will reappear.  So the user will be forced to eventually deal with the 
notes, but may choose to dismiss the note entry if time or information is not available at 
the moment of audit. 

The Note Entry window will display a status bar in the lower left explaining how many 
audits are left to be noted.  Use the Previous and Next buttons to see different audits as 
applicable.  When all notes are completed, press the OK button. 
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Audit Log Maintenance window 
 
 
This window is where you can purge or archive old, unnecessary Audit Log records. 

 

 
 
This window is accessible in one of these ways, depending upon what you opted when 
you first installed Auditor: 

• From the Shortcut Bar. 
• Log on as System Admin (‘sa’) and go to Tools > Setup > Auditor > Auditor 

Setup.  Then choose Audit Log Maintenance and then the Process button. 
• Log on as System Admin (‘sa’) and go to Tools > Utilities > Auditor Setup.  From 

the drop-down, choose Audit Log Maintenance and choose the Process button. 
 
Description 
 
The system Audit Log is the physical table RSAS015 in the DYNAMICS database.  Over 
time, this log can grow quite large.  You can use the System Settings panel to specify a 
warning to be issued to system administrators when a specified threshold is reached. 

The purpose of the Log Maintenance window is to permanently archive and purge the 
log file.  You can follow the on-screen steps in order to determine how many records are 
in the log file, and then define a query to select records for purging. 
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Pressing the Define button will open an interactive tool for defining a query to act on the 
log file.  You can filter which records you want to archive using this tool.  If you need help 
with this feature, please contact us or your reseller for support. 

It is recommended that you export the records to xml using step 4 or performing a 
backup and permanent archive of the DYNAMICS database before purging the log. 

Once you press Purge Selected Records, the selected records will be deleted from the 
log file and cannot be recovered without a proper restore. 

  

Audit Reporting using SmartList 
 

 
 
To get to this window, go to View > SmartList, or simply press the SmartList icon on the Microsoft 
Dynamics GP toolbar. 

 
Description 
 
All system audits are tracked in a single table in the system database, and can be 
reported using Smartlist.  Smartlist is the only built-in way of directly viewing audits.  
Using the features of Smartlist, you can filter and sort your audits and export them to 
Word or Excel for further evaluation.  You can also double-click on and Audit and the 
Audit Inquiry window will open giving you details about that Audit event.  The Audits 
object appears automatically in Smartlist after the product is installed. 

For more technical reporting of audits, you can access the audit table directly in SQL 
system by querying the table RSAS015 in the DYNAMICS database. 
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An Overview of E-Sign 
 

E-Sign is an “electronic signature” function that gives you the ability to specify that 
changes to certain fields in the accounting system require the signature of the User 
making the change, and optionally, an approver’s signature.  Users and Approvers “sign” 
actions by entering their Dynamics GP password. 

Setting up E-Sign requires three simple steps: 

1. Select which Users will be E-Sign Approvers.  This is done on the System 
Settings window. 

2. You require a Signature or Approval for changing a field by creating an E-Sign 
Signature Definition (or “Signature”, for short).  Here you can attach a Reason 
Group and optionally assign specific Approvers to that field’s Signature 
requirement.    You can also specify to which Users and Companies this 
Signature applies. 

3. Attach the Signature to each field on each window where that requirement should 
be active.  This is called a Signature Assignment (or “Assignment” for short).  
Assignments are made via a Wizard that allows you to simply open the window 
where you want to assign the Signature, click on the appropriate field, and then 
click an Assign Signature button on the Wizard window. 

Repeat steps 2 and 3 for each Signature requirement that you have and E-Sign will be 
completely set up. 
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E-Sign Signature Definition Maintenance window 
This is where you specify which fields will require a signature or authorization to change them. 

 

This window is accessible in one of these ways, depending upon what you opted when you first 
installed Auditor: 

• From the Shortcut Bar. 

• Log on as Sys Admin (‘sa’) and go to Tools > Setup > Auditor > E-Sign Signatures.   

• Log on as Sys Admin (‘sa’) and go to Tools > Utilities > E-Sign Signatures.   
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Description 

The E-Sign Signature Definition Maintenance window allows you to set up all of the 
requirements for a Signature.  Here you will specify a Name and a Description that will 
be displayed to the User when they are asked to approve a change.   

You can specify whether you want the User to give a reason why they are making a 
particular change with the Reason Code radio group.  If you choose the Required radio 
button, then you must also select a Reason Group that will be presented to the User on 
the Approval Needed or Signature Needed windows. 

If you only want the User to sign the change they are making, but do not require a 
separate Approver’s signature as well, uncheck the Approval Required check box.  If 
approval is required, however, then you will also need to choose a Denial Reason Group 
and one or more Approvers. 

 

Assigning Approvers 

When a User makes a change to a field that requires approval, they will be provided with 
a lookup of the applicable Approvers for that Signature.  An Approver can be used only if 
the following criteria are met: 

• They are an Assigned Approver on the Signature Definition, or ‘All Approvers’ is 
marked on the Signature Definition 

AND 

• The Approver has access to the Company in which the change was made. 

By default, when you setup a new Signature Definition, the ‘All Approvers’ check box is 
checked.  This means that any Approver can potentially be used when this Signature is 
invoked, as long as the Approver has access to the Company in which the change was 
made.  If you add new Approvers on the System Settings window, then they will 
automatically be available to all Signatures with ‘All Approvers’ checked.  However, if 
you uncheck ‘All Approvers’, then you must assign specific Approvers to that Signature.   

 

Company and User Access 

You can make a Signature apply to only specific Companies or Users by unchecking ‘All 
Companies’ or ‘All Users’ and then selecting the Companies or Users that do apply. 

Note that each Company that this Signature has access to must have at least one 
Approver assigned that has access to that Company.  If you see the words “No 
Approvers” to the right of the Company Name then you must either select an additional 
Approver or remove access to this Company. 

 

Assigning the Signature 

Now that you have completed your Signature Definition, you need to tell E-Sign where 
the Signature should be activated.  You do this by checking the Actions button at the top 
of the window and choosing Assignments from the drop list.  This will open the Signature 
Assignment window, which is described later in this document. 
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Importing and Exporting Signature Setups 

You can Export a Signature Definition and all of its associated Signature Assignments to 
a text file. This can then be Imported at another site or just saved as a backup.  You do 
this by first displaying the Signature that you wish to Export and then clicking the Actions 
button and choosing Export from the drop list.  This will create a text file with the 
Signature Name as the file name and “.signature” as the extension.   

To Import a Signature Definition, click the Actions button and choose Import from the 
drop list, then browse to the location of the Signature file that you want to Import.  If a 
Signature with the same name as the one you are trying to Import already exists in the 
system, you will be asked if you want to replace it.  

One thing to keep in mind is that the Approver assignments, Company Access and User 
Access will not be Exported or Imported.  If you Import a Signature, then ‘All Approvers’, 
‘All Companies’ and ‘All Users’ will be checked.   
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E-Sign Signature Assignment window 

This is where you tell E-Sign to which windows and fields a Signature applies. 

 

This window is accessible in one of these ways, depending upon what you opted when you first 
installed Auditor: 

• From the Shortcut Bar. 

• Open the E-Sign Signature Definition Maintenance window and click the Actions button, 
then choose Assignments from the drop list. 

• Log on as Sys Admin (‘sa’) and go to Tools > Setup > Auditor > E-Sign Signature 
Assignments.   

• Log on as Sys Admin (‘sa’) and go to Tools > Utilities > E-Sign Signature Assignments.   

Description 

The process of creating a functional Signature is not complete until you assign that 
Signature to each field on each window where you want that set of signature or approval 
requirements to be activated.  The E-Sign Signature Assignment window is where you 
link a Signature Definition to the window fields to which it applies.   
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Working with Signature Assignments 

The process of assigning a Signature to a window field is Wizard-based: 

1. Click the Add Assignment button ( ).  This starts the Signature Assignment 
Wizard. 

 

2. Click Next and you will be asked which Signature you would like to assign.  
Select the appropriate Signature and click Next again. 
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3. You will now be presented with a page of instructions for how to proceed.   

 

4. You will also notice that the Assign Signature window opens to the lower-left. 

 

5. Next, open the window where you would like to assign this Signature.  In this 
example, we will open the Vendor Maintenance window by going to Cards > 
Purchasing > Vendor. 
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6. Click on the field where it should be assigned.  In this case we will assign to the 
Check Name field.  The Assign Signature window will now be populated with the 
information for the field on which you clicked. 

 

7. Finally, click the Assign Signature button.  A message should appear on the 
window indicating that the Signature was assigned successfully.  The process is 
now complete. 

If there are other fields on this window where you would like to assign this Signature, 
then simply repeat steps 6 and 7.  If there are other windows where you would like to 
assign this Signature, then repeat steps 5 through 7. 

To remove an assignment, highlight it in the list and then click the Delete button ( ). 

You can make also changes to an Assignment by highlighting it in the list and clicking 
the Edit button ( ).  This will open a window where you can change the Form, Window 
or Field Name manually.  Typically, we do not recommend using this window, however 
you may be asked to do so by Rockton Support. 

The Actions button contains options for manually registering and unregistering the 
triggers that enable the Signature Assignments.  Again, this is not something that you 
would normally need to do unless requested by Rockton Support. 
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E-Sign Approval Needed window 

This is where a User requests approval for a change that they have made. 

 

This window opens automatically when a User makes a change to a window field that has a 
Signature assigned to it. 

Description 

This window will open after a User makes a change to a field that has a Signature 
Assignment, if the Signature Definition has the Approval Required option set.  The User 
making the change is called the Requestor. The Requestor must complete the Approval 
process or click Cancel before they can proceed.  If the Requestor clicks Cancel, the 
change will be undone. 

Enter or select the Requestor’s GP User ID in the Requestor field.  This field will be 
defaulted to the User that is currently logged in, however this can be over-ridden. This 
may be necessary if the Requestor is making the change while logged in as another GP 
User.   

Next, enter the GP User Password for the Requestor. 

Enter the Reason for why the change is being made.  This field may or may not be 
required, or may even be disabled, depending upon what was chosen on the Signature 
Definition.  You can type a reason into this field, or select one from the drop-down list. 

Enter or select an Approver for this change in the Approver field.  Choosing the lookup 
will give you a list of all valid Approvers for this Signature.   
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The Approval Process 

There are two options for obtaining approval for a system change.  The simplest option 
is to click the Approve button. This will open the Approver Password window so that the 
Approver you have selected can enter their password at your computer. Once the 
Approver has entered their password, the Approval process is complete. 

The simple method is only useful, of course, if the Approver can physically come to the 
Requestor’s location.  However, if this is not possible or convenient, then there is 
another option.  If an Approver is currently logged into Dynamics GP, you can submit an 
approval request to that Approver by clicking the Submit button.  This will give the 
Approver the ability to approve or deny the request at his or her own desk. 

Clicking the Submit button will put the approval in a status of Pending and the Requestor 
will see this in the status area in the lower-left corner of the window.  This will 
automatically open the E-Sign Pending Approval Requests window on the Approver’s 
computer.  Here, they can approve or deny this request, or any other outstanding 
(Pending) requests.  A more detailed description of the E-Sign Pending Approval 
Requests window follows later in this document. 

Once that Approver has approved or denied the request, the status area on the E-Sign 
Approval Needed window on the Requestor’s computer will reflect this result 
automatically.  Also, if the request was denied, then a pop-up message will display the 
reason that the Approver entered for denying the request.   

The Requestor can now click OK to complete the Approval process. If the request was 
denied, then the original change that the user made will be undone.   

It should also be noted that while a submitted request is awaiting completion, the 
Requestor can cancel that request by clicking the Cancel button.  This will remove it 
from the E-Sign Pending Approval Requests window on the Approver’s computer. 
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E-Sign Signature Needed window 

This is where a User enters their Signature for a change that they have made. 

 

This window opens automatically when a User makes a change to a window field that has a 
Signature assigned to it. 

Description 

Similar to the E-Sign Approval Needed window previously discussed, this window will 
open after a User makes a change to a field that has a Signature Assignment.  However 
this window will open if the Signature Definition does not have the Approval Required 
option set.   

Enter or select the Requestor’s GP User ID and Password, and optionally the Reason 
for why the change is being made.  Then click OK. Clicking Cancel will undo the change 
that the Requestor made. 
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E-Sign Pending Approval Requests window 

This is where you can see changes that have been approved or denied for a window. 

 

This window will open automatically for Approvers that have pending approval requests. 

Description 

This window opens automatically on an Approver’s computer when a Requestor submits 
an approval request. If an Approver sees this window, he or she should try to approve or 
deny the pending request immediately if possible, because the Requestor cannot 
proceed until the request has been completed.  For this reason, though this window can 
be closed temporarily by clicking the OK button, it will continue to be opened 
automatically until all pending requests are completed. 

To complete a pending request, double-click it.  This will open the Approval Inquiry 
window.  On this window, you will see details of the request as well as an Approve 
button and a Deny button.  The approver must choose one of these buttons and enter 
their password to complete the request. If they are denying the request, then they must 
also enter a reason for why they are doing so. 
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E-Sign Approvals window 

This is where you can see changes that have been approved or denied for a window. 

 

From a window that has had completed approvals, go to Additional > View E-Sign Approvals. 

Description 

This is where you can view all changes that have been approved or denied for a window.  
If there has not been any E-Sign activity for a given window, then the Additional menu 
option will not be available. 

You can see details of a particular approval or denial by double-clicking it. 
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Appendix A 
 

Audit Group Export File Format 
 

The Group Maintenance window provides an Export capability that will create a text file 
containing the setup information for that Audit Group.  This file can then be used to 
import this Audit Group information at this same or another site.   

Note: Some data elements in the Export file contain the Database Name.  So if you 
plan to Export into a different company, then you will need to edit this file and 
change all references to the Database Name to the appropriate value. 

Each record in the Export file contains one data element, so there are no delimiters. The 
following diagram describes the general layout of the Export file: 

< Group Definition > 
< Group Master Definition: RSAS019 > 

< Group Table Master Definition: RSAS023 > 

[ Table Definitions – one set per Table Audit ] 
< Table Master Definition: RSAS001 > 
< Table Primary Key Master Definition: RSAS009 > 
< Table Field Master Definition: RSAS002 > 
< Field Options Master Definition: RSAS024 > 
< Field Mappings Master Definition: RSAS025 > 

< Group SQL Table Master Definition: RSAS028 > 

[ SQL Table Definitions – one set per SQL Table Audit ] 
< SQL Table Master Definition: RSAS026 > 
< SQL Table Primary Key Master Definition: RSAS029 > 
< SQL Table Column Master Definition: RSAS027 > 

< Group Form Master Definition: RSAS022 > 

[ Form Definitions – one set per Form Audit ] 
< Form Master Definition: RSAS011 > 
< Window Field Master Definition: RSAS010 > 
< Field Options Master Definition: RSAS024 > 
< Field Mappings Master Definition: RSAS016 > 

Table definitions (enclosed in < > in the above diagram) will have the following format: 

Table Name 
Number of Fields 
Number of Records 
Field Name { one per Field in this Table } 

[ Record Data – one set per record in this Table ] 
Field Value { one per Field in this Table } 
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Appendix B 
 

Audit Log Archive XML Format 
 

The Audit Log Maintenance window provides an archive capability that will create an 
XML file containing the information in the Audit Log Master (RSAS015) table.  The 
following is the format of that file: 

<CompanyID>   CMPANYID 
<ProductID>   PRODID 
<ProductName>  PRODNAME 
<AuditType>   RSA_Audit_Type 
<FieldNote>   RSA_CB_Field_Note 
<Date>   RSA_Date 
<EventID>   RSA_Event_ID 
<EventType>   RSA_Event_Type 
<FieldName>   RSA_Field_Name 
<FieldNote>   RSA_Field_Note 
<NewValue>   RSA_Field_Value_String 
<OldValue>   RSA_Field_Value_StrOld 
<FormID>   RSA_Form_ID 
<FormName>   RSA_Form_Name 
<FormTechName>  RSA_Form_Technical_Name 
<RecordKey>   RSA_Record_Key_String 
<TableID>   RSA_Table_ID 
<TableName>   RSA_Table_Name 
<TablePhysName>  RSA_Table_Physical_Name 
<TableTechName>  RSA_Table_Technical_Name 
<Time>   RSA_Time 
<WindowName>  RSA_Window_Name 
<WindowTechName>  RSA_Window_Technical_Nam 
<UserID>   USERID 
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